Airship Community

Xbox One X system shuts down randomly in game

I bought Battle Chasers for the Xbox One X this weekend and was playing it today and had several issues with the system just turning off in the middle of the game. It would start right back up and would then happen again. Its been at random times in the game. One during the victory screen after a battle. Another at the beginning going in to a battle and then another time during travel on the map screen. This is not happening in any other games on the Xbox One X. I’ve played several hours of Tomb Raider, Banner Saga and Songbringer recently.

Any ideas?


Does the entire system shut off completely, or the game just exits?

The whole system shuts down or goes in to some sort of sleep mode. I hear the audible beep of the system when it shuts down and the light on it goes off and then I can turn it back on from the controller. Once the system seemed to come back up pretty quick and other times it was a full boot with the xbox boot screen.

I have played a few other games after like Path of Exile and Tomb Raider and it doesn’t exhibit the same issue. Battle Chasers is the first and only time I have seen this behavior.


i have the same issue. Game crashes at random points.
Screen is stuck or console shuts down. this is the only game i have this issue

How often does this happen? Is it consistent, or at totally random intervals?

It’s been totally random. I tried to play it again to see if I could pinpoint when it happens but it’s random. I was on the world map moving around and it just went to a black screen and then my xbox turned off. When I turned it on again it came right back up, and it said ‘Resume’ for the game on the home screen so I clicked it and it was at the exact same spot i left off on the map. So I played some more and then it completely shut down while i was in a dungeon and when I turned it on again it installed an xbox update so it was a complete shutdown.

I’ve only played about 45 mins and am still in the starting areas looking for knolan and monika.

Let me know if I can do anything else to help you troubleshoot. I work in I.T. so I’m used to troubleshooting problems.


-I had the problems in the last room from junktown. I ran to the dungeon boss than freeze. (3-4 times on diffrent locations in this screen)

-Before and after some fights in the dig.

-at the gate that leads to deadwatch after i get back from the dead realm.

-several points in deadwatch

Im Playing on Xbox OneS on Disc (no scatches on disc)

I real wanne play this game.
If there is a possibility i would like to try the game in the downloaded version and would send you the hardcopy. Maybe there was an error in the production.

Also i encountered that normaly all fights start instanty, but some fights on the overwolrd map or in dungeon the fights take 15-40 seconds to start including loading screen.

I’m on an Xbox one X Project Scorpio edition. Physical disc no scratches.

Maybe it’s the disc.
I hope a mod will notice this thread

Maybe so. It says Hooper is a Lead Programmer. Hopefully they can figure it out. I really want to play this game on the big screen.

This is happening to me as well. I was about to do boss at The Dig, but my Xbox One S freezes and then shuts off. I have rebooted Xbox several times as well as performed full shutdown/unplug. I have also reset the dungeon and completed again, but the problem remains. I can’t continue forward in the game due to this. This is a game-breaker for me and the most disappointing part is not being able to complete what has, up to this point, been a great game.

Are the developers or programmers looking in this case. I realy want to play on this game, because its amazing. But at the moment i dont want to replay the last 10-20 minutes because of the crashes ;D

The answer is no, the ps4 version is still broken after 2 patch and almost 3 months and apparently all console version are broken. Hope nothing from them

yeah thats realy sad, because this is realy a good game(if there were no crashes)

@Thrak75: Have you tried reinstalling the game completely? I wonder if something is broken in the install. This isn’t an issue most users are experiencing.


  • How frequently are you crashing?
  • What version number do you see in the main menu? I just want to make sure you have the latest patch.

I am out of town for the holidays. I’ll try that when I get back home. I’ll let you know.

Ok, got back and uninstalled the game. I then downloaded it from the Xbox store and I have been able to play the game for hours without a problem so far. I got through the iron outpost and the sewers under the inn. I am now making my way to Junktown.

I’ll update if I have any issues. So is there something wrong with the physical disc installer?

@Thrak75: Great, I’m glad to hear that worked!

What I was trying to say is that I think the first time, something went wrong with your install for whatever reason. Maybe a file got stomped or something.

After installing from disc, your Xbox should have patched you up to the latest version. It did, correct?

Yes, it was updated after the disc install the first time.

I’m having the same issue on my PS4. Randomly during the dig boss fight the game crashes and shuts down my system. I have a downloaded version of the game. Still not sure what patch version of the game I have yet.

Will try and check that later as I’m kinda scared to turn my ps4 back on. Each time this happens my lights dim in my house like there’s been some electrical fault or something.