Airship Community

Xbox One Iron Post Achievement Bug

I recently started playing Battle Chasers: Nightwar and after completing the Iron Post dungeon the achievement for completing that dungeon will not unlock. I have tried reseting my Xbox and signing out of my account and then signing back in. Neither method has fixed the problem. I don’t know if this is a bug from the previous patch but all of the other achievements seem to be unlocking just fine. Please fix this bug. Thank you for your time!

Sorry about that!

Have you tried completing the dungeon again? Also, make sure you exit to the world map; don’t beat the boss and do “Quit to main menu” immediately after.

Yes I have completed the dungeon multiple times on all the different difficulty levels. I have tried leaving the dungeon and reentering it. I have even uninstalled and reinstalled the game offline so that it was prepatch, started a new game, completed the dungeon again and still the achievement will not unlock for me. I would greatly appreciate it if this was fixed in a future patch. Thank you again for your time. By the way, I am loving every second of this game! I just wish this achievement wasn’t bugged.