Airship Community

[Windows] Game Freezes while in Battle

Hello, I’ve just bought the game but since the first battle I always have the same inssue (for every single battle!).

After 30 secs in battle the background sound stops and after you finish the battle the game freezes and I can’t even close it. I have to turn off the computer by pressing the power button.

I’ve alredy tried:

  • vsync on/off
  • low grapich config
  • windows/full screen
  • normal/safe mode(dx9)

Here are my Computer config:

Steam Computer Information:

Computer Information:
Manufacturer: INTEL_
Model: DH55HC__
Form Factor: Desktop
No Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i7 CPU 870 @ 2.93GHz
CPU Family: 0x6
CPU Model: 0x1e
CPU Stepping: 0x5
CPU Type: 0x0
Speed: 2926 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Unsupported
AVX: Unsupported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 7 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce GTX 260
DirectX Driver Name: nvd3dum.dll
Driver Version:
DirectX Driver Version:
Driver Date: 11 14 2016
OpenGL Version: 3.3
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: NVIDIA GeForce GTX 260
VendorID: 0x10de
DeviceID: 0x5e2
Revision: 0xa1
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 22.20" x 12.52" (25.47" diag)
56.4cm x 31.8cm (64.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 896 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Alto-falantes (Realtek High Def

RAM: 8125 Mb

UI Language: English
Media Type: DVD
Total Hard Disk Space Available: 953766 Mb
Largest Free Hard Disk Block: 167928 Mb
OS Install Date: dez 31 1969
Game Controller: None detected
VR Headset: None detected

And I’ve upload the log file.

Please guys could you help me? I really want to play this game. Thanks !

output_log.txt (25.6 KB)

almost 1 month and got no Reply, I bought the game thinking I would have at least some support but seems you guys don’t care much about custumers. Next time I’ll get a cracked version for any of your games. Thanks for stolen my money

Hey, sorry you’re having trouble.

Given that no one else has reported a similar issue, and lots of people have played the game, I’m thinking there could be a problem with your computer. Do you have random hangs with any other games?

That video card is also pretty old. You can try turning all the settings to low; maybe you’re running out of video memory, and/or your video driver is hanging your computer?

You could try uninstalling and reinstalling the game, just to make sure no files got corrupted or anything.

After reinstalling the game it started working as expected. Thank you Hooper !

After 25 days that I bought the game and my vaction is over, I’ll be able to play now :sob:

Hope you guys Earn lot of money :money_mouth_face: to be able to contract more people and give players a better SLA to solve their problem.

Anyway thanks a lot for your help Hooper at least you took your time to help me ! I wish you a good new year :slight_smile:

Hey that’s great, I’m glad it worked! Enjoy.