Airship Community

Upcoming Changes

Hey all!

We’ve already gotten some feedback from reviewers and users that we’re putting into action. We hope to have a patch live in the next day or so on Steam to address a few things (consoles will follow after - takes longer):

  • Pacing: Some users have mentioned that time to level in the back half of the game is a bit too grueling, so we’re going to start flattening the curve a bit to help alleviate this
  • Economy: We like for gold to be a scarce, valuable resource, but it might be too scarce. We’re actually fixing a bug we just found that was preventing the proper amount of gold from dropping in some minor loot containers (like crates and barrels) which should address this.
  • More Loot: You should find more loot in dungeons, too.
  • Cheaper Blacksmith Upgrades: The cost to upgrade the Blacksmith and unlocking crafting in town is going down.
  • Bug Fixes: We’re working on myriad bug fixes, including a reported crash on PS4 that happens during some extended play sessions.

I’ll update this list as things change.



Will the patch on GOG be on the same day as the Steam patch?

I’m not 100% sure. It’s pretty easy to update GoG, but we’ll see.

I have a issue where some Cutscenes I get a pink screen.

Is there a way to switch my platform from GoG to Steam?

Cool. Just wondering where the updates for GOG will fall in the list of the

Ugh, just lost my game to the PS4 glitch and it corrupted my save. I’d also like to report that cut scenes come up nothing but pink. I won’t be playing again until the glitch is patched. LOVED what I did play.

I too just received this exact issue and had the pink screen during the last cutscene of the dungeon. The save file also did not save to the cloud so i am out nearly a full day of play and the iron fortress completion as it apparently errored out right as a fight started, hence during a save. Puts a not so sweet taste in my mouth for a day one purchase on PS4 where i can’t get a refund. :confounded:

Hi I’m not sure if this is the right board but you’re a dev and I need help. My name isn’t in the credits when I opted for it as soon as it was available. As well, the two extra codes for the chaoseater and the portraits are not working when I enter them.

Way to go AS! The game is lovely and it’s wonderful to see devs working hard to fix issues that arise.

Keep up the awesome work.

Congratulations on release of Airship Syndicates first game! The fixes sound great! I think we need a secondary save method other than the autosave because some peoples files are getting corrupted, and losing all progress sucks. Also, when can we expect to get the soundtrack and final comics? (I’ve been itching to model to the soundtrack on my playlist!) Again, Congrats!

Just noticed that the soundtrack is up for sale on Steam. Will you guys be adding it to our inventory for those who are supposed to receive it as backers?

I’m seeing some performance issues on my Xbox One. I’m not very far yet, but I’ve had it freeze when I went to fight the last bandits at the end of the first dungeon (required a hard restart). I’ve also had the game slow down significantly when it is raining (like at the gate south of Harm’s Way near where you find the letter the blacksmith references). Let me know if I can provide other info that would be helpful.

The change look great, but don’t Nerf thing to much, i really like the fact that the game is pretty challenging, don’t want to see that vanish.

Also it would be fun to be able to play on heroic, but not just in dungeon :).

Keep up the good work.

Yeah we’re trying to be careful!

Yes! Should be coming today!


Sweet! :grin: Looking forward to it. Thanks.

The collector has a piece of gear Alumon appears to wear at Knolan’s expense. Also very very minor, if you fish from way back and throw really weak you can hit a spot fish can’t get to.

Hope you are fixing the boss not spawning in the sewers and a trophy that won’t unlock. Trophy (Go On…) is for completing a beastmasters hunt. Tried it several times but it won’t unlock.

This is where the boss won’t spawn. All the audio cues are there but just not the boss. I fought him once before the patch but could’t beat him. I tried again after the patch and this happend. Wanted to try without the patch again but than the savegame isn’t compatible anymore. And instead of giving a warning that the save isn’t compatible anymore it just crashes to playstation menu