Airship Community

Unable to upgrade to physical copy

Having some trouble upgrading to a physical copy for Xbox one, anyone know of a fix? my pledge package is unlocked and i can progress to the final page that says to checkout but it will not progress any further

Hello, I have the same problem. I’m blocked at the same point. Is there any solution for this problem ?

It functions with chrome but not with firefox if it can help.

thanks very much, chrome works fine, must be some problem with firefox itself

@strangelove I’m having the same problem as above. I tried on Chrome and on Firefox, but no luck. I don’t know if my being registered in Australia has anything to do with it, but like I said before I’d like to send it to my Dad’s place in the U.S. Please help!

I just tried again on Chrome in Bootcamp (Windows 10) Same issue. “Unable to generate a checkout. Please go back to the store item and try again”.

I’ve changed the delivery address in the survey to an address in the U.S., but no dice. :frowning:

Yeah, no clue there. The guys that run our payment service will have to look at it. If you haven’t yet, PT, please send that info to and we’ll do our best to get you sorted. We’ll get it to you one way or another.