Airship Community

Switch version bugs

I couldn’t take the wait for my backer copy anymore and bought a copy from Best Buy, but I will be spreading the Battle Chasers love and giving my backer copy (when it arrives) to a friend for their birthday next month!

Anyways, I’ve put about ten hours into the game and it’s been playing pretty smoothly, but I ran into some bugs tonight and figured I’d call them out in case the devs are monitoring these threads…

  1. The weird delay/stutter during the first hit of a battle is happening sometimes. I thought this was fixed/patches in the other versions of the game?

  2. I encountered a crash which seemed to happen after I won a few sequential battles against lesser enemies with “One-Hit Wonder” bonuses awarded.

All in all though, I’m really happy with how the game turned out. Thanks for taking the time to give us a quality release!

1 Like

it’s still in the ps4 version sadly. They’ll really need to tackle this sometime. I don’t want their reputation hurt because of performance issues while most of the game plays well in regards to design.

i kinda think the engine they used might just be too much of a hassle.

I also forgot to call out how nuts the HD rumble is when fishing. I don’t know if it’s actually a normal level of rumble and it’s just pronounced when playing in portable mode, but I had headphones on and I could hear them buzzing. Maybe dial them down a bit, guys?


But no seriously I want more rumble, maybe a setting tweak or something? I believe you can toggle/mess with it in the Switch OS settings.

You can either turn it on or off, there’s no “level” I don’t think. And when you change it, it’s system-wide. I don’t mind the rumble, I just think it needs to be lowered a bit.

Someone on another forum mentioned if you put the Switch into sleep mode, the game clock keeps ticking. That seems like a bug to me.

I progressed up to the Mine in the game and the game froze on a victory screen. (could see sprites in the background moving still but no input was effecting the game to exit the exp rewards.)
I tried sleepmode and going to switch home menu, reconnecting controllers, etc (tried what i could think of and waited a total of maybe an hour trying to get it to progress)
eventually I decided to close the game via the switch menu and when i reopened the game my save data was gone.
im apprehensive playing again in case i get further or to the same point and the same bug breaks my game again, which sucks because i was really enjoying it

Well that’s kind of terrifying… I might copy my save file just in case something similar happens to me.

EDIT: Crap… I think I just hit the same bug. I just won a battle after finishing and leaving a dungeon and I’m stuck at the victory screen with the portraits and XP bars. I have Gully, Garrison and Knolan in my party, just shy of leveling up to level 12. I really hope I don’t lose my save if I close the game…

yeah thats the same screen i was at, the XP bars. my party was about lvl 11 or so.
im pretty sure if you wind up closing you will lose your data :frowning:

I tried a bunch of things for a good 10 or 15 minutes; I left it on the screen for a while, tried pressing buttons, holding buttons, pressing Home and browsing some News before going back to the game. I don’t know if it was luck or me giving it enough time to work itself out under the hood, but after I quit the game from the Switch home menu and relaunched it, my game save was still intact. Times like these I wish the Switch had cloud saving (it’s coming in September). Then if it did get corrupted, you could re-download the last save it uploaded.

I’ve only played the game about 11 or so hours so far, but I would have been crushed if I lost my progress. I’ve seen some people say there was a bug in the Steam (PC/Mac) version of the game where people were losing their saves after putting in 20 someone hours. I don’t know if I’d have started over if I lost that much progress.

I’m not quite at a Mine in my game, but I think I’m about to be… I hope the problem doesn’t happen again and blow away my save this time. :frowning:

i tried doing a bunch of stuff like you mentioned too, i guess mine was still attempting to save or accessing the data at the time when i closed it so i lost everything. i started over and just finished the iron keep again but i just feel really apprehensive putting more time into now.

The game kicks me out to the world map every time I try to enter the gambon cave.

I meant the Banog cave

i didnt have a problem with that cave (bug wise i mean). im not really sure saving and exiting and then reloading the game might help?

Finally got back to the Mines after losing my save data. get to boss. about to strike killing blow.
“The Program closed due to an error” -frustration-
load game and am sitting outside of the mines. -more frustration-

Red Monika bomb’s aren’t render properly in Switch version…

I have a Spanish version of the game and the Switch too. Switch and game are updated to the last version.

Here is a screenshot

Both fire and Ice bombs are rendered the same

I’ve found a render bug, too. Gully’s third boost ability isn’t properly rendered on the Switch, showing blue and pink stripes.

Had a couple hard crashes and the freeze after a lycelot bomber suicides into the party. Other than those, the horrible framerate in most areas is the biggest complaint so far.