Airship Community

Stonegrove Ruins glitch [PC - Steam version]

Hi all! First of all, I’d like to say a big ‘thank you’ to Airship for Battle Chasers: Nightwar, because it’s one of a very few games that managed to captivate my full attention for about a month now. I’ve been greatly enjoying the experience.

And yet I’ve got a pretty nasty glitch in Stonegrove Ruins, which doesn’t let me go up the very first stairs. Here are the screenshots of what happens:

My team just drops dead down into the fog of war upon approaching the stairs, and then restarts from the beginning without any damage, but there’s nothing I can do to cross this spot. Has anyone encountered the same glitch, or am I the only such lucky guy here?

Thanks in advance!

Hey, @Pilgrimman!

First off, thank you so much for playing our game! We’re very sorry you’ve run into this; it’s a pretty frustrating bug.

The two suggestions I would have for you to try, unless you’ve already tried them, are:

  1. first to try restarting the game and seeing if the fall is still there
  2. I see you’re playing on PC, so try verifying the integrity of the game files on Steam. You can do this in your Steam Library by right clicking Battle Chasers and selecting Properties > Local Files > Verify Integrity.

If either or neither of these work, let us know!

Hi Andres!

Thanks for the actual reply, I didn’t even think you would react :smiley: In fact, the problem was indeed solved after restarting the game. I went to do some other stuff first, and then returned to Stonegrove Ruins the next day, and it all worked like a charm. Got my ultimate burst for Calibretto at last!

Thank you again, and hope you’re not going to stop developing games like this one!

Very glad to hear that, @Pilgrimman, and no worries; we’re still working hard as a studio on very cool things we can’t wait to share with ya’ll!

Want to know!! :sob: