Airship Community

Steam Controller Support

I emailed Airship Syndicate Support and was recommended I post here in the community.

Running Battle Chasers: Nightwar on OS X 10.12 in Steam.

I’m trying to use my Steam Controller and it says the game is fully supported, but as soon as I launch the game the Steam Controller does nothing.

Below you’ll find the layout my controller says it’s utilizing. I could try and create a custom controller layout (setting up the D-Pad Up to W, D-Pad Left to A, and so on . . .) but thought I’d get your input first.

Thank you very much for your time!

Just to check, are you running steam in big picture mode? If so, exit it and run the game out of big picture mode. I had problems with my PS4 controller when launching the game from big picture mode. Launching the game out of it solved my issues. Hopefully, it’ll sort out your issues too!

Thanks for the reply @dioprem.

I tried as you suggested and the controller worked better, not great though when taken out of Big Picture Mode.

The joystick properly functions now to control the characters, it looks like the B button is mapped to the Space Bar, the A button is Enter, there’s no Z or X buttons that function properly.

I think I’ve gathered that the Left Trigger might be the E button . . .

Is this what your experience was?

I was directed to post here “as our devs are in there able to provide you with technical solutions.”

I’d love to hear how this was intended to function. My goal is to use it with the Steam Link, which wants you to run in Big Picture Mode.

My problem (and eventual solution) is listed here: Bug?: PS4 left joystick keeps pulling up (steam version)

Thanks @dioprem for the additional support.

Reading some of the articles listed in your post I’ve realized that the controller settings never seem to switch to a “controller,” as in I never get prompts that change to A - B - X - Y, it’s still asking for the E button to be pressed, or Esc to be held, Space Bar to be hit. So it’s as if it doesn’t actually recognize there’s a controller present.

But then again, it does . . .

I found a setting that explains exactly how it’s performing!

This is the exact layout the controller is functioning in, the “Desktop Configuration.”

So . . . how do I get it to recognize I’m using a “controller?”

So I’ve spoke with Steam about this quite extensively, to which the gist of their reply was . . . “it appears this is a bug that the developers are aware of.”

The Steam Controller not functioning in Big Picture Mode is a bug, hopefully something that’ll be remedied sooner than later, and unfortunately playing out of Big Picture Mode you’re stuck with that clunky Desktop Configuration.

So I decided, if I was going to be able to play this game, I’d make my own controller scheme as a bandaid until a patch comes through.


Hopefully I got it unloaded properly to the community where others can benefit from it as well.

It’s too bad a member of the development team never responded, could have at least stated it was a known issue and mentioned what their timeline was for a fix. Instead of having to go through Steam Support as if it was a problem on their end.

Hey, @Siilus; this is actually definitely a bug with the Steam controller drivers running on OSX, so we’ve been waiting for Steam to patch their controller software. It sounds like from their answer that they don’t have any intention of doing so, so let’s see what I can do.

I should be able to run a development build through Steam and try debugging to see what the Steam controller comes through as, but just for the sake of getting as much information as possible, could you verify for me both screens for the configuration setup that’s currently causing you trouble?

I assume it looks something like this:

Hey @ortizgames, thanks for the reply.

My two screens look like this:

This is in Big Picture Mode. As mentioned above, I had to create some other control schemes in order to work around playing the game.

@Siilus Oho! Could you click rearrange controller order? If the Steam Controller is not at the top of the list, move it to the top.

I only have one controller I use with my computer, so when I go into the “Rearrange Controller Order” option I’m only given a single selection to choose from.

Arrghh I had resolved another bug like this! Ah, well, too good to be true. I’m looking into it.