Airship Community

(Steam and GOG) New Patch is Live! Oct. 12, 2017. v.23098***UPDATE***

******UPDATE - The Patch is now live on Steam, GOG and PS4. You can check to make sure you have the latest version if you check the top right on the title screen. It should read v.23098 :slight_smile: ***

Hey Everyone!

We’ve gotten some great feedback since launch and have a bunch of bug fixes and balance/quality of life things in this patch that we hope improves everyone’s experience. One common point of feedback was involving grinding near the mid/late game, as well a big decrease in difficulty when certain perks/weapons and combos were acquired. These are all addressed in this patch. NG+ should also be a lot more challenging now! This is now live on steam for PC and Mac and we are working on pushing to GOG as we speak.

Consoles: Our #1 focus right now is fixing the crashes and potential save corruption that players are encountering on PS4. We hope to have a fix soon, and when the fix goes live, these balance tweaks will be included as well. Xbox One will also see these changes at that time.

Without Further Ado!

Patch Notes:

  • The Blacksmith found a bunch of gold in his old apron: Cost to upgrade the Blacksmith has been reduced to 500g for the first upgrade and 2000g for the final upgrade.
  • Vendors became a little less greedy and you can sell items to vendors for slightly more.
  • Fishing comparison display is fixed. We figured actually seeing accurate numbers was a good idea.
  • Perks should always unlock at level 6. If they didn’t unlock for you, you should see them unlocked with this patch now.
  • Getting into combat while interacting with the Surveyor should no longer make you unable to interact with anything when returning from combat
  • The name/description for the items required for Gully’s Ultimate weapon were flipped (Dragon Scales and Dragon Heart Phylactery)
  • Smoothed XP curve for mid to late game to require less replay of dungeons to level up
  • A wider variety of items will be available as loot in chests, especially in early/mid game dungeons when crafting isn’t as accessible
  • Increased gold acquired from creatures, chests, boxes/crates. Also, fixed a bug where minor loot objects (crates, barrels, jars etc) were giving too little gold outside of the first dungeon and Strongmont.
  • Various typo fixes
  • Enchanting Shrine will be guaranteed to spawn in Path of Fangs and Deadwatch.
  • Fix for a bug some people were encountering in which some of the Hunt bosses (sludge mound and king slime) never spawned and players became stuck
  • The room containing The Shade of Belevros in the Iron Outpost should spawn a loooooot more now.
  • Fixed a bug in which Alumon would actually NOT join the party. We found him and forced him back in your party if he wasn’t unlocked for you, and he should be appropriately leveled and not naked
  • Lycelot Alpha Trackers realized they should sometimes whiff their Claw Barrage attack and players will be able to evade its strikes now like any other attack. Also damage of it reduced slightly.
  • Fixed missing name/description for starting weapons for Knolan and Red Monika in New Game Plus.
  • Fixed an error in 2 of Alumon’s perks (Dark Mending II and Sanguine Embrace II) adding 2x the healing they should have (sneaky Alumon)
  • Increased the base level of enemies in NG+
  • Enemies around the Dig on the worldmap will be appropriately leveled
  • You should be able to turn in the Vessel of War and Glorious Vessel of War now if it was stuck for you (you will need to re-kill 10 enemies on your way back to the shrine where you turn it in though)
  • Mantle of Aramus has been changed: Places a damage shield on Gully that absorbs damage. For the next 3 turns, anytime Gully receives damage, she will be healed.
  • Clarification with the Defend II perk on Gully that specifies that the damage reduction is only when using Defend
  • Stun Immunity duration increased to 4 turns from 3 turns after a hero or enemy is stunned.
  • Re-Balanced Crit Damage perks
  • Fixed a bug with the Ring of Lost Love’s thorns value
  • Each Heroes’ Legendary Weapon power has been reduced slightly (still the best weapons in the game!) This fix isn’t retroactive, so if you already have the legendary weapons in that run, they will remain extra crazy.
  • The final boss has grown in power
  • Masteries have been rebalanced across the board
  • Perks/masteries that power up based on overcharge use have been rebalanced
  • Some of the Pirate Captains weren’t spawning, but should now spawn normally
  • Fixed a bug that sometimes caused players to be stuck on the victory screen (especially against Lycelot Bombers)
  • Some bosses will keep a tighter hold of their purses, not letting you pickpocket key items from them
  • Fixed a bug that sometimes caused heroes who gained multiple levels at once to not receive all the perk points they should have. If you’ve been effected by this, you may notice some of your heroes have more perk points than they did before!
  • Fixed a bug that prevented unpurchased hero skins from showing up in NG+
  • Opening the Bestiary in combat with a controller sometimes caused it to auto close. This has been fixed. Using B(on xbox controller) or O(on playstation controller) will close it. (keyboard always worked and hasn’t been changed)
  • Fixed a Bug in which you can get infinite xp from the king slime. We think that’s a little too much xp.
  • Arena rewards were sometimes not being awarded. This has been fixed and if you have been affected by it in the past, when you complete another arena run, any unique items that you should have been awarded and didn’t receive will be given to you. (this means if you had been robbed of something that you could’ve gotten somewhere else like a flask, and you actually got it somewhere else, it won’t be given, but key items like weapons, trinkets, recipes, quest items etc will always be retroactively given)
  • The boss of Deadwatch was incorrectly leveled in NG+ on Mythic Difficulty.

Thank you!


AWESOME. Thanks Airship!

Awesome news to hear, thanks guys! Can’t wait to see this update implemented in the near future. :slight_smile:

Seems like Ryan didn’t like you announcing this without him. He had to put the final touches of unpinning and globally repinning the news.

Thanks and great job!

Haha. i had posted it without a category so i wasn’t seeing it even though it was pinned. :slight_smile:

Guys i really need a help here! I installed and played the game for 6 hours now and then i closed it. The patch arrived and installed it. Now when i try to click on save file it doesn’t give me the option to load the game. The cursor shows the save but the continue button doesn’t show up. Anyone knows a solution? Btw i am playing on steam!

Hey I’ll PM you and you can send me your save file and we will take a look! Sorry about that

Thank you sir. I will be waiting.

I am having the same issue! i tried to uninstall and reinstall but same issue

Did either of you switch to experimental branch when we had it there?

to my knowledge I didn’t but then I am not sure what I would have done to do that. I was in the Dusklands died and rezed in town and saved it last night. Tonight I load up and the game sees my saved game but I have no option to load it just create a new one.

Updated - Just read about the experimental branch and I did not do that at all.

And the newly created save file can be loaded. I tried to start a new game and restarted the game and nothing strange happened.

Hey all, we got a hold of some save files and are taking a look at them and why they aren’t loading. We are going to rollback the update in the meantime until we can fix the issue to make sure everyone can get into their saves correctly

It looks like we found out what was going on. Everyone’s saves should be ok. Making sure its what we think it is

I am so sorry for the stupid question, but where does one go to get this patch? And I didn’t see anything regarding it, so I ask: does this help with finding Belvaros in Deadwatch? I am on my 7 run through now, haven’t spotted him yet. Yes, I released him. (On accident, I thought he was a bandit whose friends trapped him in there as a joke)

He has his own hall with pillars, he just stands there and is super easy to find once you’ve freed him from the iron outpost sarcophagus.

Fix incoming shortly! Was a minor issue. If anyone was having trouble loading their save, they can rest assured their save is ok. Sorry about that!