Airship Community

[SOLVED] Only getting 1 fps in intro, menu, and world map

After not playing for a few days whenever I start the game I get 1 fps during the intro, main menu, and on the world map. I’ve tried reinstalling the game, deleting all the folders for it, running it in dx9, and restarting my computer. Nothing has worked so far and I’m running out of idea. I also verified the Cache on steam.

Hey, @Ziek25! We’re really sorry to hear that. Could you post your output_log.txt file on here for us? You can use a service like PasteBin or something to upload it and post the link here.

The log file is located in your Battle Chasers Steam install folder, something like
C:\Program Files\Steam\steamapps\common\Battle Chasers Nightwar\BC_Data\output_log.txt

It’s still currently happening after the patches.

Is this a desktop or a laptop? Any chance your somehow playing through an internal onboard 3d chip instead of your video card? Has anything changed there lately?

Are you having trouble with any other games, or do they all run at normal framerates?

I have a desktop and I have a nvidia 970. Every other game runs perfectly fine. I even bought grim dawn yesterday and that runs perfectly fine.

I don’t know if this helps but the THQ Nordic sign pops up normally but then after that the frames drop

That does give us a hint, but not much.
We’ve been trying to figure this out on our end but aren’t getting very far.

Could you try the following things for me:

  • Go into the Video Settings and making sure you’re running at a resolution that is good for your machine
  • Also in Video Settings, turn off VSync
  • In Graphical Settings, turn your Graphics and Post Effects Quality settings all the way down.

Lastly, how are you checking framerate? If you’re using something like Fraps, try disabling that application, then when the Airship Syndicate logo comes up in the game, press F2 to use the in-game FPS counter.

I’ve tried all that and I’m using the steam fps counter. Yesterday I tried manually adjusting the games setting through nvidia setting and that didn’t work either. Also steam beta didn’t change anything either.

Looks like the problem fixed itself. I’m not going to complain lol

Huh!! Well then!
We’re sorry you had to deal with all that! But as long as it’s fixed, good enough for me!