Airship Community

[PS4] Several Trophies not unlocking


I’ve had several trophies not unlock for me, while I did met the requirements.
This problem has been here for me since launch, but most of the time, the trophies would pop after I loaded the game back up.

However, since a day a 2, no trophy is popping for me. It’s several actually.
Don’t know if listing would help, so I won’t, haha.

Any tips/solutions?


I don’t mind bumping my own topic…

But I’m still not getting trophies awarded even though I’ve unlocked them.
I’ve completed New Game +, but I still didn’t get the trophy that should unlock at STARTING a NG+…

I feel like I’ve already done everything in this game, I should’ve earned the Platinum, but something is not making my trophies pop…


@SpiritReacher At the moment we only have an open bug for the 100% Bestiary completion trophy. If you have additional trophies that have not been granted to you, please list them here.

I finished the fishiary yesterday and noticed the trophy didn’t pop up, so I exited and restarted the game a couple of times to try to fix. Later I started new game plus and the trophy also didn’t pop up.
This was on PS4.

So I started up the game and decided to start working a bit on my new game plus and after playing for about 20 to 30 mins the trophies I was missing popped up.
So all is well now, just giving the update.

That is really strange… I’m glad that worked for you, though! Sorry about the weirdness, @KeeChak!