Airship Community

PS4 LAUNCH ISSUE - Screen Goes Black

I’m a kickstarter backer. Ive redemeed my code in PS4 - EU region. It accepted the code. Then ive downloaded and tried launching the game. It doesnt work. The screen goes black and stays that way. The game itself looks launched and when i push the PS button it shows me as im playing the game but its stuck on black screen.

i have deleted and redownloaded it twice. its still the same. Black screen and nothing works. i cant play the game which ive helped fund. I need an urgent answer. If not i want a money back.

(Ive tried installing any updates, says my game is up to date. PS version is 500gb non-slim. Region is EU. ps version 5.0)

Thanks in advance. Urgently waiting for an answer.

update: restored the licenses in PS settings. still the same.
downloading for a 3rd time now. without sleep mode this time.

Hey Deathmasx, how long have you let it hang in the black? This is definitely unusual, we’re not sure what could cause it. We’ll see what we can find but it sounds like a unique issue.

Just out of curiosity, have you let it run for an extended period to see if it’ll eventually recover from the black screen?

Hi Strangelove
thanks for the reply. Ive waited over 1 hour in the black. no buttons worked, only the PS button which gets me back to PS main menu. Shows as its open in the background. when i return to it, still black.

Im resided in Turkey, but i dont think this affects anything. ive found this from another game which the user experienced the same issues. thats why im trying a 3rd time without any sleep mode. ps on and im monitoring the download. although its slow as im in Turkey :frowning:
not a long left though.
ill update when finished.

So it didnt work. again.
i just recorded a video. Let me know how i can send it to you

Here you go the video of it not working:

please come up with a solution. im a kickstarter backer and been waiting since the beginning!

ill keep upping this until someone gives me a satisfactory reply.

I’m really sorry! We’re kind of at a loss on this one. This is the only time we’ve heard of this happening, and we don’t have any way to reproduce the issue here so we can look for a fix.

Do you have problems with any other games?

Do you have plenty of empty space on your PS4?

@Hooper @strangelove

fair point but i paid before the beginning and not getting anything in return until now

i dont have any problems with any other games. Digital or with disc. They play fine.

I just checked and there is 108gigs of free space on the PS

hey @deathmasx. Do you have any external USB’s or harddrives plugged into the ps4 or any other programs running in the background?

hey @Airship-Steve

no i dont have any External USB’s or harddrives. No background running programs.

This may be a silly question, but have you restarted your PS4 or do you leave it in sleep mode when you are done playing? (i dont think i’ve restarted my ps4 in months). If you usually use sleep mode, maybe try powering off the ps4 all the way and then turn it back on.

I always shut it down when im done playing. Dont use sleep mode usually unless im downloading something. and ive restarted it many times since this error with Battle Chasers

Hi all

please dont let this slip. Im really looking for a solution from you guys. Im ok with a PC code. Just please hear my cry for help!!

I think its about Turkey. Cause i am from Turkey and have same problem.Someone send msg to me about same problem and he is from Turkey too.

Bu arada adam ilk defa duyuyoruz demiş.8 günden beri uğraşıyorum.Mail yağdırdım heriflere.Adamların kendilerinden haberleri yok. Sacma salak geçiştirme cevaplar veriyolar. Surekli uplıycam . Seni baya sallamıslar. Belki bi cozum bulunur.

Thanks for this info, @Tutakamuru; that may be a clue. We’re looking into this.

ok i am waiting. Thanks for reply

@Tutakamuru: If you set your PS4’s language to English, does the game launch for you?

i just changed it to English and it worked. it has launched after a few seconds from the initial "all the heroes starting screen"
thank you guys!

if you can, please patch this so the new buyers from Turkey dont get this problem.