Airship Community

Processor problem (PC)


Since I bought the game I have a problem. This game is using almost all of my processor ressource ! I’m at 88% on the map and 90% in a dudgeon. And sometime it goes to 99% and my PC crash.
I don’t have any problem wwith any other game big or small.
Here is my config :

Operating System: Windows 10 Famille 64-bit (10.0, Build 16299)
Language: French (Regional Setting: French)
System Manufacturer: To Be Filled By O.E.M.
System Model: To Be Filled By O.E.M.
BIOS: P1.90
Processor: Intel® Core™ i5-4430 CPU @ 3.00GHz (4 CPUs), ~3.0GHz
Memory: 16384MB RAM
Available OS Memory: 16304MB RAM
Page File: 4264MB used, 14971MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 12
DX Setup Parameters: Not found
User DPI Setting: 96 DPI (100 percent)
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.16299.0015 64bit Unicode

does anyone have the same problem ?


Hey, @Narbakov,

Your processor is not bad, but it’s pretty old now - over 4 years old, and it was discontinued this year.
What resolution and quality settings are you running the game at, and what video card do you have?

I have an NVidia GeForce GTX 1060 6GB
My settings are 1920x1080 full screen, quality and details : medium and Vsync deactivated

It doesn’t sound like it’s your hardware.
Are you playing on Steam? Could you try verifying the integrity of your game files?

Right click on the game in Steam > Select Properties > Local Files Tab > Verify Integrity of Game Files button

I tried that, and re-install it. It runs on an SSD. I tried running the game in safe mode. It doesn’t work.

Your entire computer crashes?
Could you use software like SpeedFan and see what your computer’s temperature is getting to while playing the game?

The computer scrash only if I try to laucnh any other program (like Chrome)

After a lot of tests, I have good news. I’ve found the problem and it’s not your fault and I’m sorry if I wasn’t able to think of this earlier. It was a problem of thermal paste, mine was obsolete. I’ve changed it and everything is fine now.
Sorry for wasting your time. And thanks for trying to help me the best way you could


That what it was sounding like! Very glad you were able to get this resolved :slight_smile: