Airship Community

Problem saving the game

So I was in the Deadwatch dungeon, right after getting Alumon. I was playing on hard and then at the end I got my ass kicked by the Hangman group right before the boss. As my party members are being killed I just figured I’d log out and log back in instead of waiting for Gully to be killed as well. Anyway, I end up finishing the dungeon and exploring the next area before stopping for the night. Next day I log back in I’m exactly where I were before I finished Deadwatch, dungeon still incomplete even though I clearly did. I tried finishing the dungeon again and saving again but it always comes back to that room before the end of the dungeon. My gametime still adds up but the saves doesn’t reflect my progress. What do?

That’s very strange. We’re very sorry about that, @lapugenero; I’m PMing you some details to try to figure this out.

Hey @lapugenero; I tried reproducing this issue locally using your save file but couldn’t. Have you tried using the Verify Integrity of Game Files option on Steam?
(Right click Battle Chasers on Steam > Select Properties > Select Local Files tab > Click Verify Integrity of Game Files)

There is also the possibility Steam Cloud saves isn’t syncing your saves when you quit, and when you re-run the game it might be stomping your saves with whatever’s in the cloud. I’ve had this issue with Steam before.

Alright well, before starting the game today there was a short five minute update that started downloading and now it seems to save fine. Thanks for the help!

Excellent! Glad to hear!