Airship Community

Plese, help me, I'm sick of this stupid bug and I don't want to leave the game

That’s what happen everytime when I play the game, it happens suddenly I tried everything, upgrading my pc drivers, my gpu drivers, closing msiafterburner and rivatuner before playing, closing every other programs opened in the desktop, checking the integrity of the files on steam, setting low graphics options ingame, playing on lower resolutions, setting high priority on task manager, setting vsync off both in game and in nvidia control panel, playing on fullscreen or in window mode (like in the case of the picture) but it still happens, the game graphics block but I stll can hear all the sounds of the game working, in this case during a fight I pressed the Y key on my xbox360 controller to check the enemy stats and there we are but other times it happens even at the start menu when i press continue or during the loading screen or even when I attack with whoever of my characters. It happens everytime I play since the day1 even after the 2 patches the game got… Please help me I’m going mad
here’s my output log too, I’ve already talked to a dev almost 10 days ago
output_log.txt (235.7 KB)

PC spec (I’m Italian but here’s the english specs):

Computer Information:
Model: GL502VM
Form Factor: Laptop
No Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i7-6700HQ CPU @ 2.60GHz
CPU Family: 0x6
CPU Model: 0x5e
CPU Stepping: 0x3
CPU Type: 0x0
Speed: 2592 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce GTX 1060
DirectX Driver Name: nvldumd.dll
Driver Version:
DirectX Driver Version:
Driver Date: 10 6 2017
OpenGL Version: 4.6
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: NVIDIA GeForce GTX 1060
VendorID: 0x10de
DeviceID: 0x1c60
Revision: 0xa1
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 13.54" x 7.64" (15.51" diag)
34.4cm x 19.4cm (39.4cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 6143 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Altoparlanti (Realtek High Defi

RAM: 8127 Mb

UI Language: English
Media Type: Undetermined
Total Hard Disk Space Available: 1075195 Mb
Largest Free Hard Disk Block: 558689 Mb
OS Install Date: gen 01 1970
Game Controller: XInput Controller #1 detected
VR Headset: None detected

Hey, @RedRaja!
We’re very sorry your video output is freezing up. Thanks so much for the very complete report - this is great. We already see something suspicious here in your log file, and we’re trying to track it down.

While we look into fixing this, based on the error in your log file this may be an issue related to DX11. Have you tried running the game in DX9 (Safe mode)? When you double click on the game in Steam, it should ask you to pick between the two, or if you right click on it in your Steam list it should be the second option on the context menu.

Give that a try as a workaround and see if this reduces the issues at all.

When I play in safe mode most of the times with vsync active I have fps capped at 22 and its unplayable and recently I have experienced blurry pictures on screen during the exploration phase in any of the dungeons which are annoying as hell :frowning:

We have been doing research today and came across this thread:
Apparently this is a rare crash that happens on some machines running Unity games. It does not seem to be something we have control over. Some people were suggesting it may be related to NVidia Optimus, for switching between the 1060 and onboard Intel GPU chip, but based on my research of your laptop it does not seem like Optimus is a feature on your laptop.

So from what I understand, the GL502VM is Gsync compatible if the onboard Intel video chip is disabled:

So I would first off try disabling the onboard Intel chip. How to do so is mentioned here:

Then you’d be able to run without Vsync on. That’s pretty huge for me when I’m gaming on my computer at home.

  • I’d first try running the game in DX11 like this, and seeing if you still get screen freezes. If you are not getting them anymore, I’d suspect it has to do with a conflict that Unity is causing between your onboard Intel graphics chip and the GTX 1060.

  • If you still get freezes, try switching to DX9 with the Intel chip disabled and see if the performance is any better - particularly without Vsync on.

  • As for the blurry DX9 effects, the only way to fix this is to disable Post Effects entirely. This seems like a really bad solution, so we’re looking into a special test config option to disable DOF. That should be in our next experimental patch later on.

And remember to turn your Intel chip back on after gaming! The 1060 uses up more battery.

We appreciate the patience, @RedRaja, and sorry for all the frustration. I hope this helps.

It seems I have no integrated gpu, in device manager there are no voice for integrated video cards

Try checking your BIOS instead? There’s an option in the Advanced options that reads Graphics Configuration, according to your manual:

I don’t know what’s in the options, though, and the manual doesn’t say.

It’s incredible but I do not have any graphics configuration in my BIOS, I even updated it to the latest version and nothing changed

Well that’s a problem :frowning:
Okay, could you PM us your DxDiag output? We’ll see what we can find in the logs. In the meantime we’re working on additional controls to graphical settings for our next patch.

Okay I’m gonna PM you right now, so far I can tell you that after a long game session today (2+ hours) in safe mode I did not encounter the video output freeze but I played with constant stutter of fps which went from 60 to 22 and the back to 60 almost every 3 minutes and after saving and quitting the game I got the error BC.exe stopped working

Hey @RedRaja; we think we might have a fix for the framerate issues people are experiencing by offering different modes of Vsync for differing hardware. We’re testing it in house and it should be available next patch.

As for the crash that you got quitting the game, did you have a log file from that? We might be able to see what caused the crash in the log file.

Honestly after that time I didn’t get any other crash so I don’t think I have a log file for that but if it happens in these days I’m definetely going to upload the log file here via PM

@RedRaja Great :slight_smile: Please do! And we’ll let you know when the Experimenal branch is updated.

1 Like