Airship Community

Playtest. Several Bugs

PC specs:

  1. OS: Windows 10 Home 64-bit
  2. CPU: Intel Core i5 4210M
  3. GPU: nVidia GeForce GT 820M
  4. RAM: 8 gb
  5. Native screen resolution: 1600x900
  6. Controller: Dualshock 4 via Bluetooth

Game settings:

  1. Resolution: 1600x900
  2. Fullscreen: On
  3. Vsync: off
  4. Quality: High
  5. Post effects quality: High


  1. Gamepad button prompts are not displayed in the game at all.
    BC 2017-09-06 20-37-02-738

  2. Fishing category doesn’t have its title in every shop in the game.
    BC 2017-09-06 21-37-00-587

  3. In some cases skills descriptions are not displayed in the Combat Abilities menu:
    Open Combat Abilities menu for any character.
    Choose any ability to see its description.
    Press LB or RB to change character - see that ability description is not displayed.

  4. Graphic of the Buy icon in the Collector shop is not displayed.


  1. In some cases Abilities Cast Time doesn’t work properly.

Hey, @HarryDemch,
Could you try going to the game’s Properties on Steam, going to the Local Files tab and selecting Verify Integrity of Game Files? It wouldn’t fix all of these bugs, but hopefully it would address some of them.

Hey, @ortizgames!
Thanks for your reply!
I did as you said, but all files got verified, Steam didn’t load any additional files, like it is nothing wrong with the game on my machine.
Nothing changed in the game, unfortunately.

@HarryDemch, I’m thinking the big unique issue I’m seeing for you is the lack of button prompts.
Could you check your controller preferences in Steam (Under Steam > Settings > Controller > General Controller Settings) and make sure the PS4 Configuration Support is turned on?


  1. Inconsistent naming.
    Somewhere it’s said AP, somewhere - Attack Power.

  1. Confusing Perk description.
    It should say “while using Defend”.

  1. Seems like wrong Buff name, but I’m not sure.


  1. Shortcuts in Dungeons are resetting after restarting the game and resuming the Dungeon.

@ortizgames, yes, it turned on.
I turned off my DS4 and connected my Logitech F710, which supports XInput. Xbox button prompts appeared in the game!
Tried connecting DS4 with usb cable - still no prompts.

Seems like Verifying Integrity of Game Files resolved several issues:

  1. Knock-out Gloves proc works properly. Earlier it was just giving Stun Immune, but know it stuns properly.
  2. Sting’s Bleed was procing twice earlier, but now it works as expected.

I’m so confused.

It’s possible just exiting and restarting the game fixed those issues.
We’ll be updating the beta soon with logging enabled so we can have users send us their logs and we can better pinpoint the issues.

1 Like


  1. Fishing spot resets when resuming Dungeon.
  2. In some cases you fight Mimic twice after interacting with Mimic chest.
    Approach to the Mimic chest.
    Press Action to interact with it.
    Immediately starts fight with Mimic.
    After the fight see Mimic chest animation. After that start second fight with Mimic.

Russian Localization

  1. Incorrect display of Combat Abilities’ Cast Time in Compendium

  1. Incorrect display of Combat Abilities’ Cast Time in Battle.
    Some have missing letter, some does not display at all.

  1. Incorrect text position.

  1. There should be a space between numbers and text

  1. Incorrect buttons active zones in craft stations

  1. Incorrect text alignment.

  1. Incorrect text display.

  1. Incorrect text display.

  1. Double colon.

  1. Incorrect text alignment.

  1. Text covers arrow graphic.


  1. Missing Sorting button. There definitely should be one.

Hey, @ortizgames, I found the reason why DS4 button prompts are not displayed!
If this option is checked, then there will not be DS4 button prompts.

Oh wow!! That’s a great find, @HarryDemch, thank you!
I’ll make sure to let people know about this!

1 Like

Further testing showed that the problem is very complicated.

If “Use Steam Configuration for Non-Steam Controllers” is checked

  1. there are no DS4 button prompts
  2. controller works via usb-cable and via Bluetooth
  3. there is rumble

But, if “Use Steam Configuration for Non-Steam Controllers” is not checked

  1. there are DS4 button prompts, yay!
  2. controller works only via usb-cable
  3. there is no rumble

Here’s my Steam Controller settings.
Steam 2017-09-16 00-23-56-330

@ortizgames, should I keep adding bugs here or better create a thread for every bug?


  1. Burst meter resets after restarting the game.

@HarryDemch Please make new threads for individual bugs; it helps us keep better track of then, and it’s even better if you can offer details about how to reproduce them.

I created new threads for every actual bug in this thread, so this one can be closed.