Airship Community

New Patch on Experimental Branch v.23288 (Updated)

UPDATE: We’ve updated the experimental branch again with some fixes to things that were supposed to be fixed but weren’t working quite right.

Hey Everyone!

We have some more bug fixes coming soon! You can get a look at them early in the experimental branch! Once we determine the patch is stable, we will push it live.


Remember, this is risky! Please do this only if you’re excited to help us test some changes.

One of the most important things you can help us test are the validity and stability of existing save files with these updates. It’s important that you back up your existing save before opting into the experimental branch, in the event problems occur!

To back up your Steam save files:

Go to a directory something like: %appdata%\…\LocalLow\Airship Syndicate\BattleChasersNightwar<Your 64 bit steam ID here>\saves
Copy the save files there into a new, separate directory outside of the BattleChasersNightwar directory.

Every time you launch the game, Steam will copy the save files from the cloud into your saves directory. (When the game shuts down, it does the reverse.) Because of this, if you’re trying to copy your save files back into the saves directory, start Battle Chasers: Nightwar up first. Then while you are at the START screen, copy the save files into place. If copy saves over before launching, they’ll get stomped by the Steam cloud saves.

Switching to the Experimental Branch:

Right click the game in your Steam library and choose Properties > Betas
In the field next to “Check Code”, enter the following pasword: ireadthenotes
This should unlock the Experimental branch
In the drop down, select the Experimental branch to begin downloading it
To switch back to the normal game, select “None – Opt Out”.
Your help testing these changes is hugely appreciated. Following are patch notes detailing some of the changes:

Patch Notes for build v.23270

New Features

  • New options added to the Options menus:
    • Keyboard remapping is finally here for PC/Mac! Simply go to Options > Controls and rebind away!
    • Setting to play videos
    • Show interaction outlines in combat/dungeons
    • Hold left click to Move
    • Rumble


  • Completing a dungeon in Mythic mode also counts toward the Completing all dungeons on Legendary achievement.
  • Added a fix that retroactively awards you the 100% Bestiary Completion achievement if it was not awarded to you properly on earning it.
  • Airships now remain spawned on the World Map when they have been spawned prior from completing a dungeon.
  • Players can now flee from Hunt bosses if they realize they’re in over their heads. You will flee back to the World Map when you try to escape from a Hunt encounter.
  • Hunt Quests have had their levels adjusted slightly to give players better warning about their difficulty.
  • Players who defeated Bhargus but did not receive the Purgatory Stone should now find it in their inventory.


  • Switching characters while viewing a Mastery perk will update the UI accordingly with the next character’s Mastery Perk.
  • We added an entry for the highest difficulty completed for a dungeon in the Dungeon Codex.
  • You will not get a Legendary Dungeon warning for a dungeon in progress.
  • Skipping through the Combat Victory screens now appropriately skips the reveal animation for your loot so you can see it before you exit combat.
  • You now get toasts for loot obtained when skipping the Combat Victory screen altogether.
  • Minor UI fixes.


  • Various minor fixes.


  • Fix for hang when accessing the Tolkas Arena.
  • Fix for Razer headset drivers crashing.
  • Cinematic video sound is now tied to the Music volume in options, so you can keep the Voice high and better listen to dialogue over the music and sound effects.

Thank you!



Typo in RU version in remaping menu.
“Особе” - “Особое”.


Also I can’t open Inventory on World Map on gamepad. Y not working anymore =/
Gamepad - Microsoft Xbox One S. It worked without any problems before patch. I guess remaping involved here.
Edit: Well, suddenly, inventory now on “menu” button.

Still can’t fine any airships. Checked all map - nothing.

Is there a way to remap the Y button to open the Inventory?
Enjoying all the other changes. Thanks!

In the Perks screen, Y gamepad button no longer switches perk section, but closes the menu like B button does.

Thanks for the rest of the fixes!

I confirm this. It’s annoying…

Thanks for the feedback, guys! We’ve got fixes and are working on getting it out on Experimental again soon!

Another problem im having is in the Ability Menu i cant scroll downwards at all.......

i used to be able to use the mouse wheel but now it just wont go down?
What am i doing wrong here?

Good catch; @qwert_44702; we’re able to repro this in the studio, too. Looking into this.

@qwert_44702 if you restart the game does it keep happening? I restarted and i can’t get it to happen again

I tried everything from shutting down the game…restarting my computer and it just would not work…i ended up getting totally mad and unimstalling the game and re-installing it and so far its working///i was round level 21…and 1 thing i did do because i dont know what to do is…when i first got this game i was looking high and low for a way to move your party by mouse and i found info on making a BC.ctg file and i did but when i found out bout the experimental patch i deleted that file…am i supposed to keep that file?

! thing i was able to do was click on the menu and hold and i could barely move it up and down but as soon as i let go of the left mouse button it would snap back to the top…
I couldnt scroll down to see the other abitlites i had.

But uninstalling the game and re-adding the patch its working but im worried later on down the road.

Now as i think bout it…it seemed the whole key board was getting sluggish and everything…like id have to hit a button multiple times to get it to grab hold.

Ok heres something else ive noticed for sure when Gully cast heroism the icon on the screen aint appearing by the heroes name but the buff is there…almost think theres other buffs not appearing.

And ive yet to see 1 single airship

Thanks for the extra info! As for heroism, Damage Shields will only show up as a bar over your health bar. There is no buff icon associated with them.


I thought there was an extra bar but i see colors in a messed up way…so thanks.

Another thing thats been bothering me for quite a while the artifact sword and the red rusty sword i cant sell them…is that done purposely or a bug?

you can make them into better weapons later.