Airship Community

Missing backer rewards

I put in the codes and they unlocked (code was accepted and I got the instructions). The chaoseater isn’t in my inventory and the portraits aren’t in my options. I am playing on PS4. Any advice?

Hey, @paperdawl! We’re sorry for the confusion. A handy guide has been posted to the forum already here:

If you’re still having issues, let us know, and we’ll do what we can to help.

I entered my codes last night for the backers extras they went through. I Closed game and checking it today they do not show up in game when I try to reenter the codes they come up invalid please help. Playing on PS4

Yeah… I have done all this and still nothing.

Same here, I feel like some people had a problem having the codes register at all so the “solution” is to enter them right after the opening cut scene and then they register. The thing is we’re having a different problem and no ones taking a second look at it. I have entered the codes after the cut scene, saw a pop up saying I unlocked the rewards, went into game and there are no rewards. Then in a panic just like commented above I exited out and tried to enter the codes a second time but didnt receive any sort of message as if the codes have already been used. I’m hoping there is a solution that doesnt involve me starting the game over

The rewards are viewable in specific ways. The portraits are tricky because the option to change them are only viewable in-game no in the main menu options screen

@Captainamerica2002 when you say it looked like it went through and then you closed the game, do you mean that you closed it before loading the save?

Just double checking, but the codes need to be entered for each save slot that you want it unlocked on. And in your inventory you are looking for a book and a chest (for the recipes and the explorer pack).

@Airship-Steve yes I entered codes and it said I had unlocked them. I Closed the game before loading my save to see if they were my inventory. When I loaded my save the next day nothing was in my inventory. I tried re-entering the codes they now say invalid code when I enter them. Thanks.

Yeah… this is what I have told them three times and still no answers.
They just keep implying I don’t know where to look for them… and I do.
Other people in the community explained that part before I even put this
topic up.

I’m really sorry about that, @Paperdawl.

You have the latest patch, right? On the main menu do you see v.23114?

For me I selected the file, watched the cut-scene, exited the game, entered the code, message confirmed i entered the code, clicked on the file to reenter the game checked my inventory and nothing was there. After that I tried entering the code on every save file and they arent registering anymore.

I am having trouble too. But mine seem to be different problem then everyone saying in here. Yes my PS4 is up to date with latest Patch which read it as v.23114. Now the problem is i entered my codes and nothing is happening whenever i entered my codes and i get no message telling If it has been activated.

I see PS keyboard when entering the code but After i entered my code and PS Keyboard gone and background stay black or fade out. I have already playing game and i load save to see if it work or not and it didn’t.

@Airship-Steve, @Hooper I updated and entered my codes and everything unlocked and is in my inventory. Thanks. @Paperdawl try it after the update.

I haven’t been on yet. I will check when I am home

I updated and looked. Nothing. I started a new game to see if they come
up… Nothing.

I updated and tried again and… it actually worked for me lol, also i tried it on my file i had been playing on so no restart needed :slight_smile: @Mobin1 have u ever had the confirmation message pop up before? I know i tried entering the codes with just the letters and got no confirmation pop up are u including the dashes while u type? just a shot in the dark idk if it will actually help, good luck @Paperdawl I hope u end up finding a solution

Maybe I will give that a try.

Yes caps letter with dash eg. TRYI-1111-WORK-0000, I never got any pop up message before or after either way.
Maybe i need to send videos to someone to look at it what wrong with it. I need to know who should i sent my email to with videos.

However i am going it again later with Video.

EDIT: My problem has been solved but i have no idea how it happened. Thank you for those backer rewards.
Here what i did that it seem to work. I just had to Restart my PS4 then start the game and i didn’t touch my controller and I watch that intros. Then after that where i get to screen that say press X and so i did.
So I put in Chaoseater code 1st. And it work and pop up message came up. Maybe i am suppose to enter the chaoseater code 1st in order before any other code.

Thanks for the update, @Mobin1! We’re looking into why this is happening, but we’re really glad you were able to get your rewards.

Well it sort of worked. I have access if I start a new game … But it
doesn’t work with my existing one.