Airship Community

Manarift dungeon clearing issue

So am i doing something really wrong or why can’t i provide the room before the boss enough shard energy to open the door even though i’ve cleared every single room and tried to do every single thing in those rooms THREE times, yeah you heard that right, i’ve reset the dungeon 3 times trying to get through it but everytime something or another stops me from doing that.

The first time i run out of crystal shards was because i used them on a machine that let me upgrade my armor and accessories. I mean why is this even possible? Being able to proceed shouldn’t be reliant on limited items that you can accidently use on something optional, granted the machine does ask if you’re sure you wanna use them but still, not the best game design in my eyes.

The other 2 times i was able to light the upper shard portion but not the lower for whatever reason. The only thing i can think is that i might need to kill every enemy in the dungeon because that was literally the only thing left to do. There were some supposedly alive enemies in the room with the laser eye thing(i hate these things btw) but there were none in sight so my guess is they clipped through the map like what happened on my second try, except this time i couldn’t even see them through the floor lol.

So am i just supposed to keep resetting this dungeon until the enemies actually don’t fall through stuff or do something else that somehow i’m missing?

Those crystal shards are only for side content. Your progress shouldnt be blocked at all by lacking them. For those 2 crystals you need to have both floor plates lit to interact with the center piece. (step above the switch to light the floor, step below the switch to light the floor there) then interact with the switch. should be able to do the same for the bottom. let me know if that doesn’t work, as that would make it a bug which we will look into

OHHH!! You have to stand on those 2 panels quickly before the other shuts down to get it activated. Now i feel kinda dumb :frowning:. Yeah i kinda thought those were tied to the shards couse pretty sure i couldn’t get even the first thing in that room lit up to spawn the stairs the first time around and then later it seemed to work after lighting some of the shard places around the dungeon but i suppose something else did the magic work there.

So this was a case of understanding the reguirements wrong on my case. Thanks a lot for clarifying that, now i can continue on :slight_smile:

1 Like