Airship Community

[MAC][Steam] game unplayable after intro video

I’ve played the game on a windows machine and it works fine but when trying to play on my mac the game gets stuck after playing the intro. when I played the beta it worked fine but after the release it gets stuck after the intro video. I have heard that I need to update to a new operating system but the steam system requirements says that it’ll work on 10.9 +.

Computer Information:
Manufacturer: Apple
Model: MacBookPro11,3
Form Factor: Laptop
No Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i7-4980HQ CPU @ 2.80GHz
CPU Family: 0x6
CPU Model: 0x46
CPU Stepping: 0x1
CPU Type: 0x0
Speed: 2800 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
MacOS 10.10.5 (64 bit)

Video Card:
Driver: Intel Iris Pro
Driver Version: 1.2
Driver Date: 0 0 0
OpenGL Version: 2.1
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 0 Hz
VendorID: 0x8086
DeviceID: 0xd26
Revision: 0x8
Number of Monitors: 1
Number of Logical Video Cards: 2
Primary Display Resolution: 1440 x 900
Desktop Resolution: 1440 x 900
Primary Display Size: 13.03" x 8.11" (15.31" diag)
33.1cm x 20.6cm (38.9cm diag)
Primary VRAM: 0 MB

RAM: 16384 Mb

Hey @woobear; we’re very sorry this is happening to you. What does the bug look like?

As a side note, we had an issue where the Mac build on Steam would lose focus on launch and would pause after the video, so you need to click on the screen for the game to unpause. This was supposedly fixed, but it may fix your issue.

on my mac my game stops at this loading page right after the video and doesn’t ever complete. the bar still lights up but it doesn’t go anywhere.

28 AM

I also found that I can not skip the intro video. Ive tried pressing and holding escape and ‘e’ but the skip video never comes up.

I did try to click on the screen to see if the game would re focus but unfortunately it did not fix my problem.

Thanks for your help

Could you post your log file for us? It’s usually located in Users/YourUsername/Library/Logs/Player.log
Hopefully you can find it there.

just for future reference I found the Player.log file in: Users/YourUsername/Library/Logs/Unity/Player.log

is there a specific part your looking for because my log is more than the allowed characters

I should have posted here. I’ve got the same issue on my Mac. Let me know which part of the log file I should copy/paste here.

You can PM the logfile to me directly.

Just to consolidate - I sent you a similar message on a different thread (for a PC user with a similar issue). I’ll stick to replying here.
Two questions:

  1. You mentioned updating the Mac OS version -are you saying updating my whole OS? Would that work?
  2. I don’t see any logfile named Player.log in the /Users/YourUsername/Library/Logs directory. Mind pointing me in the right direction.

I’m kind of a newbie when it comes to using Steam…

  1. I have heard people had success with updating to Siera, but since steam says it should work on 10.9 then it should work on Yosemite which is 10.10

  2. To find the log you need to have hidden files showing.
    a) Open Terminal found in Finder > Applications > Utilities.
    b) In Terminal, paste the following: defaults write AppleShowAllFiles YES
    c) Press return.
    d) Hold the ‘Option/alt’ key, then right click on the Finder icon in the dock and click Relaunch.

my log file was in: Users/YourUsername/Library/Logs/Unity/Player.log

hope that helps

sorry i did not understand your question properly since you are on a pc your log location is going to be different than mine.

sorry about that


Sending over the log file now.

Out of curiosity, how do I revert things back so that the hidden files aren’t showing in my Finder?

Sent you three PMs with the info

In Terminal, paste the following: defaults write AppleShowAllFiles NO

not sure if you got the upload but I PMed you the log

Hi there. Wondering if there were any updates. Still haven’t been able to play the game. Thanks for looking into it. I appreciate your help.

I’m experiencing the SAME bug. Stuck on loading screen following video.

I’m on Yosemite, but the min specs say 10.9, and I’m on 10.10.

I cannot upgrade to Sierra due to software compatibility issues with other programs I use for work.

Is this actively being fixed? I know this has happened to several people.

We are actively trying to figure this out, @inkfromblood, but we’re still trying to pinpoint the cause. Might you lend your assistance by PMing me your log? You can learn how to find it here: [PC/Mac] How to find Log/Save Files

@ortizgames @Hooper

Might you still be figuring same issue for PC as well referenced [PC][Steam] Game not starting after intro ?

No update in that thread

@CNelson We are looking into it, and hopefully will be able to garner more info from people with this issue using the next patch.