Airship Community

Linux test branch is up!

We now have a test branch ready to try for Linux users!

In your Steam Library:

  • Right-click Battle Chasers: Nightwar, and click Properties from the menu
  • Switch to the Betas tab
  • Choose linuxtest from the drop-down

Please report any issues you find in this thread. If you have a problem with the game and find a workaround, post that, too.


We are using Wwise to play sounds, and on Linux, this requires libSDL2. Steam should ensure this is found. If that doesn’t happen, the game will fail to start.

Directions to install libSDL2 for Ubuntu can be found here:

Thanks again, and sorry it took longer than expected to get this ready!

1 Like

Does it have controller support?

I’m trying it but the Xbox 360 wireless controller i’m using does not work. Game launches though.

Works after i enabled Xbox controller support via Big Picture mode and went back to normal mode.

1 Like

Awesome! Glad to hear it.

It also worked with an Xbox One controller. I don’t recall doing anything special first.

I think it’s because i didn’t have the Xbox controller configuration enabled in the first place.

So i had to enable it. Runs great so far.

Arch Linux here.

Very good job so far! Thank you so much for this. Been waiting months for this game.

Oh yes regarding shipping sdl2 with the game…

This is from the sdl2 wiki.

“When shipping a Linux game on Steam, do not ship a build of SDL with your game. Link against SDL as normal, and expect it to be available on the player’s system. This allows Valve to make fixes and improvements to their SDL and those fixes to flow on to your game.”

Huh, interesting. That didn’t seem to happen on my test system, but maybe I had missed a step somewhere.

@Cxpher: did you have to manually install libsdl2? Or was it already there?

The Steam Client will set up the dynamic loader path so that a known-good copy of SDL is available to any program that needs it before launching a game. Steam provides both SDL 1.2 and 2.0 in this manner, for both x86 and amd64, in addition to several add-on libraries like SDL_mixer.

On Arch Linux though, I’m using the Steam native application which does not enable the Steam runtime but instead, uses libraries manually installed via the repository. To that extent, you could say that my sdl2 library was installed directly from the Arch community repo by me since the Steam native application runs with the Steam runtime disabled. I’d imagine Solus does something similar.

Ubuntu however, will use the Steam runtimes via the regular Steam application.

Ok, thanks for the info, @Cxpher! Much appreciated.

I’ve updated my post to reflect it.

No problem. Now that you have it on all 3 pc platforms, bugs can easily be isolated to whether they are platform specific or related to game/Unity.

Congratulations and thank you for such a great game. Thank you for making it multi platform.

1 Like

I’ve tried out the beta briefly. Seems to work well on Ubuntu 16.04 with a Nvidia 960 and core 2 quad! Wired 360 controller seems to be also working fine. Slight oddity with the game not starting full screen even though the defaults are set that way? The game only actually went full screen after reapplying video settings. Also some of the video cutscenes display artifacts and ‘blockyness’ when replaying. Apart from that exploring, combat and the map mode seem to all work fine.

1 Like

I’ve just pushed a new build live for Linux. If you look in the top-right on the main menu, you’ll see v. 23748.

This build fixes a few issues:

  • Shouldn’t get the “corrupted save” message the first time you make a new profile
  • Videos no longer look blown out (too bright)


Just wanted to ask if this means that if I redeem my product key now, it will count towards Linux sales? I’ve been holding off redeeming it to ensure it gives a Linux +1 :slight_smile:

just tried the beta myself and got a few issues.
first off black video on the first launch.
relaunching while in window mode magically turned the game to render on both my screens and blinking blue for a few seconds before starting.
some occasional glitches where i got brightly colored triangles all over the screen(see linked video)
rendering glitch video
and finally it managed to crash the entire X server probably due to the triangle glitch i guess.
on archlinux with the 396.24 nvidia driver(980 card)