Airship Community

In-Game Codes Not Redeeming on PS4 -Solved

Solution: Restart the game.

I’m not sure if the servers are overburdened or it’s a bug.

  1. Select “Enter Code”
  2. I enter code and select “Enter”
  3. The screen stays dimmed indefinitely and nothing appears on screen.

I can interrupt by pressing X. A click sound after first pressing X and then the enter code opens on a second press.

I have encountered the same issue

Same for me. I was trying to redeem the Chaoseater

Same issue for both Chaoseater and Portraits code on my end.

Same here. Enjoying the game so far though

My portrait and Chaoseater codes aren’t working either, but I am loving the game so far!

Yes same with me. Able to type in code but nothing happens. Tried with spaces and no spaces. Since can put in -

I just quit the game and tried the codes again and they worked.

1 Like

Confirmed this worked for me too. Will update OP.

Did you guys also get the items? I didn’t

There are no items, at least not for the digital backers, the Chaoseater is a recipe.