Airship Community

In-Game Codes Not Redeeming on PS4 Solution

There seems to be an issue for some people redeeming their in game codes. While we look into it, if you restart the game and go to the extra menu right away before doing anything else, the codes should work. Hope this helps!


worked for me! Thanks !

This definitely works! thanks for saying it!

Yep. Had problems first, but thanks to this piece of advice, I was able to unlock the Chaoseater and the Portraits. Cheers!

Thanks I got them now, I accidentally turned off the instructions on the portrait extra cause I’m stupid XD , how do I access / change the portraits ?

Do we need to put in the dashes and are the codes case sensitive?

Pause the game, go to game settings and then you will have the option to change portraits.
I personally prefer the originals better, but they are a nice touch!

I tried doing this and the message box for each redemption popped up but when I entered the game none of the items appeared, I have been playing through the game hope that the fix doesnt involve starting over

My codes are still not working. Not sure why :frowning: I’ve restarted. Tried the process a few times since the update, and they’re not working. My Chaoseater code starts with XB - Is this an accidental Xbox code?

Hey, everyone!

We think we’ve pinpointed this issue and we’re working on a fix. In the meantime, there is a workaround for anyone still having issues where their codes say they’re valid when entered, but no changes can be seen in game:

Make sure after you’ve entered all your codes to select Continue immediately after - do not back out to the Saves menu, or your game will get re-loaded to prior to when you had entered your codes. This should be only happening on PS4.

If your codes are warning you about being invalid, please PM me and we’ll look into your issues on a case by case basis.

Thanks for your patience, everyone!