Airship Community

Gully's Mantle of Aramus blocks all actions after activation and Tavern keeper gamelocks

Was fighting a Treasure Elemental and i casted Mantle of Aramus on Gully before she died of poison and after she revived i couldn’t pick any action, so the only choice was to reset the game, but thankfully the game autosaves, so i didn’t lose any progress besides losing the Treasure Elemental chest. I tried to do this again only this time against some normal random group of enemies that killed Gully through raw damage and i got proper access to my actions this time around.

What i’m seeing here is either:

A) Status effect damage bugs it out if it’s the last bit of damage you take before the activation.
B) It’s just something that happens against a Treasure Elemental.
C) Turn order. Gully got her turn right away after dieing to the poison and reviving against the Treasure Elemental, but got a turn after the enemy group the second time when it actually worked.
D) Happens completely randomly.

The other thing that happened to me was that when i accessed the tavern keeper/bar keeper one time it got stuck on the transition animation and the keeper never appeared and i was stuck there before resetting the game, but thankfully this only happened once. It could be some kind of loading thing though because i had just teleported to the city through one of the teleportation wells and ran straight to the tavern so maybe the game just couldn’t keep up or something. I did this same thing often throughout the game too though so it doesn’t seem to be anything that happens commonly so it didn’t really bother me.

Besides those 2 occasions, i didn’t encounter any problems in the game and i can’t wait to continue after the full game comes out :).


I got the same bug against a wave in the Arena and if I remember Gully was died with poison, she revived and I got stuck. But when the arena timer was over, all worked properly after that.

Enjoy :slight_smile:

So it indeed seems to be tied to that, not that i use Gully anymore but thanks for the heads up if i ever pick her up again :).

We’ve tracked down this bug and a fix is in the works. Thanks for the reports!

Awesome, good to know :).

Oh cool, thank you for your works :slight_smile: