Airship Community

Caldeus skull for Alumon burst

How many times did it take you to run Deadwatch before you found it? All my chars are lvl 30 and I’m ready to beat the game but I STILL haven’t found the skull. I’ve run Deadwatch over 10 times (only started counting recently) and its starting to get annoying hah.
Is the best approach to maybe reset dungeon, check first room, then reset and repeat?

Just ones, AFTER I found quest for his skull. But I guess I just got lucky.

What do you mean by “quest for his skull”? Do you mean talking to the beastmaster girl? Cause I’ve done that.

You have no idea about this skull until you came to his tomb and read his story and talked with altar. When you read this story and talked to altar you got quest and you know what are you looking for.

Ok, you meant going to the actual grave site east of Deadwatch. Yup, I did all that long ago. On my 12th run through and still no skull!

Are you looking for a special event or interactable item in the dungeon? Iirc, Caldeus’ skull is discovered in the random treasure piles and/or in the bone stacks, so, if you’re skipping those, for whatever reason, that might be your problem.

In all 3 of my playthroughs, I found Caldeus’ skull in my first run through of Deadwatch.

I’ve been looting everything and interacting with everything. I saw a few screenshots of people getting the skull specifically from the bone piles with purple eyes. But I want to be safe so i just check everything haha.
Judging by the responses here and other threads, i think I’m just having colossal bad luck.

Hey @Gladstan can you message me your save file?

Sure thing. I’m playing on PS4, though–how do I do that?

Oh, I thought you were on PC. :frowning: I’m afraid I can’t do anything for consoles.

Just keep looking for skull pile resources inside Deadwatch. You can ignore everything else if you only want the skull.

You’re sure you don’t have the skull in your inventory? What does it say when you go Caldeus’ Tomb and interact with the altar there?

It’s not in my inventory. If I go to Caldeus’ Tomb to the east and interact it has the greyed out text to use Caldeus’ skull. Based on other responses from people saying they got it first or second try, I’m starting to wonder if it got glitched for me somehow? Is that possible? I’ve done almost everything else in the game.The only trophies i’m missing are for completed fishiary and everyone’s lvl 3 bursts.
Definitely strange that I can’t seem to find this skull!

We took measures to prevent this sort of thing, but it could be a bug. I would give it a few more runs on the easiest difficulty, and loot at least 5 more skull pile resources.

It is definitely strange, and I hope it’s not been too frustrating.

I just got the game this week, and I’m experiencing the exact same problem. PS4 version also. I’m not on my 12th run through, though. I just finished my 5th. The steps I’ve read about taking are 1) talk to Raha 2) go to the tomb and check out the 4 books and the altar 3) go through every bone pile (well I go through everything) in Deadwatch. Am I missing something else?

Just looting the skull piles would give you the skull, regardless of doing anything else. My guess is the game thinks it gave you the skull but you never got one in your inventory, so it won’t give you another. I’ll ask the team, but I’m not sure there’s much we can do at this point. :frowning:

I wish this happened on PC so I could at least fix your save for you.

Could you fix my save file to fight the High Captain Blothe again? :sweat_smile:
Don’t want to do another run for that… (well in fact I’ve already started one just for that…)

What’s wrong with your save?

Ho sorry @Hakan it’s just that I’m frustrated that there’s a “rule” that says it’s impossible to fight he High Captain Blothe after you defeated him once… and I would like to fight him again, that’s all :wink:

Has this bug been resolved? I’ve ran through Deadwatch at least ten times and have not found the skull.

Is there an official(-ish) cheat tool/developer’s console that let’s me put specific items in my inventory? I’m tired of wasting my time running the same dungeons over and over again until the game engine considers me worthy enough of Caldeus’ skull -_-

I think I have solved this or found a major clue as to why so many people run into this issue. I ran Deadwatch over 10 times and never found the skull so I gave up. Later, while looking for the materials to craft Dragonkind, I realized I needed to go back to Iron Outpost and release Belevros. After I did that and returned to Deadwatch, I found Caldeus’ skull in the first skull pile I checked. So, the issue may be linked to whether or not the player has released Belevros from Iron Outpost.

1 Like