Airship Community

BUG - Crash on start! need some help [EDIT: Video player related]

when I launch the game, it shows thqnordic and airship syndicate logos, then the cursor pointer changes to that of the game, and at last the game crashes.

I’d guess it’s some problem with the intro videos, but I don’t know how to disable them (or solve the problem otherwise): could someone please help?

restarted steam, pc, verified integrity of game files and updated AMD 7800 series video drivers to 17.7.2:
nothing worked

here my specs (from steam help):
Computer Information:
Manufacturer: System manufacturer
Model: System Product Name
Form Factor: Desktop
Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i5-3570K CPU @ 3.40GHz
CPU Family: 0x6
CPU Model: 0x3a
CPU Stepping: 0x9
CPU Type: 0x0
Speed: 3502 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: AMD Radeon HD 7800 Series
DirectX Driver Name: ddumd32.dll
Driver Version: 22.19.662.4
DirectX Driver Version:
Driver Date: 7 20 2017
OpenGL Version: 4.5
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: AMD Radeon HD 7800 Series
VendorID: 0x1002
DeviceID: 0x6819
Revision Not Detected
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.79" x 12.20" (24.09" diag)
52.8cm x 31.0cm (61.2cm diag)
Primary Bus Type Not Detected
Primary VRAM: -2048 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Altoparlanti (USB PnP Sound Dev

RAM: 8147 Mb

UI Language: English
Media Type: DVD
Total Hard Disk Space Available: 1124600 Mb
Largest Free Hard Disk Block: 85921 Mb
OS Install Date: gen 01 1970
Game Controller: Logitech G13 Joystick detected
VR Headset: None detected!

Hey there! Sorry for the trouble. Certain users seem to be having trouble getting videos to play, and it might take us a few days to track down why.

For now, you can delete the .mp4 videos from the steam install, which should be located in a directory like:

C:\Program Files (x86)\SteamLibrary\steamapps\common\Battle Chasers Nightwar\BC_Data\StreamingAssets\Video

(Obviously, depends on where you have Steam install the game.)

Once you do that, when the game goes to play a video, it will get stuck on a black screen. Just hold down the space bar to skip the video.

Sorry for the inconvenience! We’ll try to figure out a better solution soon.

Have your reinstalled vcredist and rebooted

Also do you have Windows N?

I tried and rename them, but I failed the “keep space bar pressed” part… will try that

edit: renamed the first two vids (2d-intro-720.mp4 and 2d-intro-1080.mp4) and it worked to a certain extent, just to crashing again.
do I have to rename all of the vids? I’m gonna try

nope… I saw something but didn’t try… was the process explained in the known bug list? going and checking

and also: I have windows 10

EDIT: reinstalled vcredist and rebooted, but nothing changes

Did holding the space bar when you get stuck on a black screen work?

I’ve edited my previous reply just now

Rename all of the vids:

Yes, you need to rename or delete all the videos (the .mp4 files).

1 Like

it seems to work without vids! thank you for now, yet I hope there’s a way to fix this: it also happened to me in the past with a couple of games (literally), so if you could please provide me feedback as how to fix that, I would be so very grateful
(as I am now for having me playing right now!)

Do you have any 3rd party codec packs like K-lite Codec or CCCP or 3rd party media players?

no codec pack and just vlc as a third party media player

I would have attached the folder(s) generated by the crash, but here I can only attach pictures…

You could upload them to dropbox or pastebin maybe?

How long ago have you updated VLC?

Same issue here, as soon as I press play, one second in I already get a “BC.exe has stopped working”.
Hitting the spacebar doesn’t work since it is so fast that I don’t even get properly in the game.
I don’t even get to the Nordiq and Airship syndicate logo part.
Tried deleting movies as suggested (also tried renaming) : no change.
Tried the “Verify Integrity of Game files” : nothing
Uninstalled and reinstalled entire game: no change.

This is on a Windows 7 64bit.

I’m gonna try and share the folders this evening;
I haven’t updated VLC in a while, maybe a few months: should I update and retry?
atm I’m playing and when I understand there should be a video, I rename the one I think is correct and watch it in a media player (and it works!): I’m a noob, but that tells me there could be a problem with the built-in media player

It seems like a very small number of people are having trouble with the video player. The majority don’t have any trouble at all, and the videos play properly. We haven’t tracked down the cause yet.

yep, I undestand that… it would have occorred a couple of time, same problem to a few and not everybody; that’s why I’m so interested in an overall solution! :wink:
thanks a ton, anyway… being able to play BC is the best reward!

1 Like

Your issue is probably more related to vcredist nto being installed properly

My experience generally either points to Windows N, vcredist being borked, or a very old codec pack that overrides the default codecs causing the bulit-in player to have a seizure

yet I reinstalled vcredist yesterday and rebooted to no avail
would you suggest a codec pack that could do the trick, so that I try and comply, pls?
standing the fact that tonite I’m gonna link the crash report folder(s), as I wrote earlier

(and also thank you for your answers)

Oh, forgive me, I forgot to mention: I read your general pointers in a main post of the forum, of what step-by-step to do;
and so I also went ahead and tried both vcredist versions that came with the game (found within the folders: "…Battle Chasers Nightwar_CommonRedist\vcredist\2010 " ) : no change
I also read on this forum about checking your VLC and update it: did that, but no change.
I also had updated my NVidia graphics card just yesterday, even prior to this games release, so that is uptodate.
Only thing I might need to check is the codec pack.
Any idea how I best should check the codecs? Or where to find the updates for that again?