Airship Community

BC.exe stopped working after 16 hours of playtime

2017-10-13

The game was playing fine in the morning but that afternoon when I tried to play, I’ve suddenly getting the BC.exe stopped working. I have put in 16 hours of playtime so now I can’t even refund the game in steam. The BC.exe crash appears on both normal and safe mode.

Please help.

have you tried verifying integrity of files in the properties>Local Files tab?

yes. an output log is also posted prior in another post.

https://drive.google.com/file/d/0B_17zJy17grBcmpFMThITEpGM0E/view?usp=sharing

also tried uninstalling and re-install

If you go to this directory, what do you see there? (The logfile is telling me there are maybe some files that shouldn’t be there.)

C:/Program Files (x86)/Steam/steamapps/common/Battle Chasers Nightwar/BC_Data/Mono/

Mono capture

a folder and 2 files as seen above.

It looks like it’s getting ready to try to get some XInput information, to find your controller.

  • Do you have a controller connected?
  • Could you post your system information from Steam? In Steam menu under Help->System Information.

No controller connected.

Computer Information:
Manufacturer: Microsoft Corporation
Model: Surface Book
Form Factor: Laptop
Touch Input Detected

Processor Information:
CPU Vendor: GenuineIntel
CPU Brand: Intel® Core™ i7-6600U CPU @ 2.60GHz
CPU Family: 0x6
CPU Model: 0x4e
CPU Stepping: 0x3
CPU Type: 0x0
Speed: 2808 Mhz
4 logical processors
2 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: Intel® HD Graphics 520
DirectX Driver Name: nvd3dum.dll
Driver Version: 20.19.15.4463
DirectX Driver Version: 21.21.13.7667
Driver Date: 7 6 2016
OpenGL Version: 4.5
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: NVIDIA GeForce GPU
VendorID: 0x10de
DeviceID: 0x134b
Revision: 0xa2
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 3000 x 2000
Desktop Resolution: 3000 x 2000
Primary Display Size: 11.22" x 7.48" (13.46" diag)
28.5cm x 19.0cm (34.2cm diag)
Primary Bus: PCI Express 2x
Primary VRAM: 1024 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Speakers (Realtek High Definiti

Memory:
RAM: 16310 Mb

Miscellaneous:
UI Language: English
Media Type: Undetermined
Total Hard Disk Space Available: 964103 Mb
Largest Free Hard Disk Block: 343655 Mb
OS Install Date: Dec 31 1969
Game Controller: None detected
VR Headset: None detected

Is there a chance it’s using the on-board Intel video chip instead of the NVIDIA Gpu?

Have you switched from plugged in to not, or anything like that?

It works now thank you. Guess the game does not force my surface to use the nVidia chip so I have to manually enable it. It works and plays now. Thanks.

1 Like