Airship Community

Battle Chasers PC - Cannot progress Mana Rifts


So first off, I’ve been having a blast with this game so far. I purchased it on a whim four days ago and have already spent 37 hours on it.

But unfortunately, I have been unable to progress further into the game for a while now.

When running the Mana Rifts dungeon, everything goes smoothly until I get to the end where you have to charge up the stones with the yellow stuff. Two of them fill all the way up, but the last one does not. Thus not allowing me to move on to the boss.

I’ve read that this depends on you having killed all of the monsters and I suspect that’s where the issue lies.

At some point during the dungeon, I will spot a red outline of a random monster stuck way below the ground. This has happened all three times I’ve tried to run the dungeon so far. I must have scoured the place a dozen times trying to find an object or anything that I might have missed.

I have tried to verify the integrity of the game files through Steam as well as restarting the game multiple times. But it just keeps happening.

Is there anything else that I could try? I’m really enjoying the game and would love to be able to finish it, but this bug is starting to put me off from playing.

EDIT: I’ve attached some images of where I get stuck and of the map on my third run through.

Thanks for reading.


The Mana Rifts doesn’t require that you kill all enemies in order to proceed. What you’re missing is the two nodes (one to the left, one to the right) of that center node. Each one will fill the center node that you’re standing on in the first image halfway.

1 Like

Thanks for your reply. I tried interacting with those but that just gives me the notification that they need more power.

1 Like

True but you have to “energize” each pylon by walking on both sides of it.
A light will shine when you will do that and when both are up you will be able to activate the pylon.
Once you did it for the first one, do the same on the second and the door will open.

Edit: spelling corrections :sweat_smile:

1 Like

Thanks Ulkhror, that did the trick… now I feel a bit silly.