Airship Community

Battle chasers gives jerks in dungeons

good, because recently I have changed graphics for a more powerful “msi 1070ti” and even in dungeon the game suffers small pulls, I do not think it is for the components of my pc, to see if you can help me.
“This happens only in dungeons and visiting areas”

-mi pc: i5-7500, msi gtx 1070ti, 16gb RAM, ssd samsung evo 850 250gb, hdd wd 1tb, evga 650w 80plus gold, msi gaming h270 m3

Hey Nando, what are your Vsync settings set to? If you press F2 you should see the in-game FPS counter; is it maintaining a consistent framerate or jumping around?

The fps vary between 3 and 5 fps downstream with vsync active and without vsync you can also see the pulls although I have not seen how many fps falls exactly, but in dungeons it seems nothing stable, I put everything to the maximum but with that graph I think not I should have problems. Anyway, when I go back to play later I’ll look at it again and I’ll confirm it, thanks for answering and I’m waiting for your help.

-by the way, I forgot that everything in ultra and 4k with vsync 60fp marks me but when it goes down to 57, 55 slows down a bit and without vsync sometimes goes up to 70.75 and down to 60-65 more or less but as you I would have to confirm.

Yeah, it sounds like your machine is unable to keep a stable 60FPS with those settings, so Unity’s vsync is jumping between 30 and 60.

Are you running in fullscreen, @Nando? Try running the game in Steam with the launch option “-exclusive”

Here’s an article about how to do this:

Yes, I play full screen, I will try to start in that way you tell me and I inform you. But is it normal that with a 1070ti not be maintained at 60fps stable ?, with a 1060 worked at 30 fps to 4k and also gave pulls but with a 1070 ti and just lose 5 fps seems strange.

We’ve seen a lot of different factors play into odd performance issues on Battle Chasers and other games. I myself at home with a GTX 1080 see weirdly inconsistent framerate on a number of games, new and old, and some of them I’ve solved by using exclusive fullscreen mode. I chalk some of that up to Windows 10’s weird new protocol for fullscreen apps.

As for BC, though, we’re still looking into possible causes for inconsistent performance, so any info you can provide us about your experience helps. Please let us know if exclusive mode helps!

good, I’ve also tried to limit fps to 30 in dungeons and it’s slowed down and worse. Regarding the exclusive mode, I do not know how to activate

Is it done like this?

-I have noticed in this area in particular that it goes up to 60 and goes down to 30fps suddenly, the frametime normally goes to 16,6ms and when it goes down to 30fps it increases to 33,3ms.

You wrote “exclusiva” - you should write “-exclusive”, with the minus sign and an e instead of an a.

I have been trying the “-exclusive” mode but I do not notice any changes, but it is very rare that when I limit 30fps I fall below 15 and 20fps and when I limit to 60 it sometimes drops to 30, this graph is quite more powerful than the one I had and I do not know if the game performs worse now …

Hmmm. Do you think you could you post a video of the issue happening for us, on Youtube or Dropbox or something? Every bit of information helps.

I have already uploaded the video, I would appreciate it if you could see it all and you will see the drops of frames and the pulls that occur in the different modes.

This is very strange. I’ll check this out and see what I can find.

Is anyone else running into this issue? If you have any suggestions, or have run into this and fixed it, please let us know what you did to do so!

I do not know anyone who has the same component and it is happening, I have tried other games and run well, I restored the system recently and I am as good as new and change graphics and increase ram so by virus issue and such is discarded and the other games that I have run well, so it is seen in the video varies quite the frametime, I think it is something more related to game optimization.
If you need something else or find a solution, please let me know, I have bought a more powerful graphic to move the game to 4k without problems and I do not understand what is happening.

good ortiz, have you verified and found the problem ?, I would like to know if it is my graphics problem or is something of the game and can you.

EDIT. I’m still doing resolution tests and at 2k it has an average of 100fps, when I return to change resolutions and go back to 2k it is suddenly limited to 40-50fps without active vsync …: S
he does not use 99% of the graphic either in certain areas.

We have a lot to do here in the office at the moment and tracking this down is not easy. It will take some time. We will let you know if we make any progress.

So if you start out at 2k and then switch away, then back to 2k, your average FPS drops?

Yes, can it be that the TV being 4k sometimes does not detect the 2k well even though the resolution changes ?, could not you tell me if this is a graphical problem even if it is? in the others I usually play well.

For clarification, are you switching from 2k to 4k, and back to 2k?

Yes yes, that’s right.

That should not happen. Hmm. Could you try changing resolution to 2K, then quitting the game, and restarting the game?
Make sure the resolution is 2K when you load back in. Is the FPS back to 100FPS?

yes, it goes back to normal, another thing is that I have realized without the active vsync it seems that it uses 98-99% of graphics but activating the vsync does not use it as it should, that is to say when falling frames could use more percentage, an example would be that it goes down from 60fps to 50fps and the graph is using 70% for example, thus being able to use 99% and give more frames. the frametime is also very unstable, it varies a lot.

edit Regarding what happened with the resolution 2k happened to me changing graphics, resolutions and limiting in rivatunner, perhaps a conflict was created in which the fps were limited, although in rivatunner the limitation was 0. I am doing verifications with rivatunner and the frametime is stable and limiting from there is controlled a bit, although I still do not understand what happens sometimes and sometimes not …

another test: vertical synchronization activated low low of 60fps up to 30fps in certain zones, with the vsync off this does not happen, I think that the vertical synchronism works badly. What I said before blocking frames at 2k is also fixed when you return to the menu and re-enter.