Airship Community

Xbox One X system shuts down randomly in game


#21

I am on Xbox One X and am experiencing the same thing. On my NG run as I went to approach the final boss the game would freeze (prior to the cutscene) and then I would force quit the game. As soon as it got back to the home screen, the console would shut off completely. Happened 3 or 4 times in a row. A power cycle seemed to do the trick, but it was an odd issue for sure.


#22

Hey, Shred!

We’re sorry this happened to you :frowning: Other people have had similar problems but they were able to fix them by uninstalling the game and reinstalling it. Have you given this a shot? If you have a disc copy, you should be able to uninstall the data from your console and then reinstall it by inserting the disc and downloading the patches again.


#23

Just happened to me too.
The game froze at the end of Strongmont dungeon just before you fight Bhargus, after the speech bubble dialog. Oddly enough the music was still playing without glitching like other times when games crash, but it was completely unresponsive. After waiting about five minutes for it to respond or auto quit, like when Xbox realizes a game has frozen, I force quit by going to the home screen and selecting quit. After the game quit, within ten seconds my Xbox shutdown; all I did was force quit the game and it somehow crashed my Xbox. When I turned the Xbox back on it did a full boot sequence, as if from full power off. Once back in the game, it happened again at the exact same spot; game froze, music kept playing, force quit, xbox shut down. This is a major bug. Please fix.

I’m on Xbox One X, non-disc download version v.23172


#24

I’m having the exact same problem as AnEngineer. NG run, exact same boss and exact same point. I uninstalled and reinstalled and it didn’t correct the problem. Impossible to continue the game without defeating the Strongmont dungeon boss. Tried to change up the party, then reset the dungeon to okay it through again. This still didn’t work either. Is there a fix, cause this is beyond frustrating. On standard Xbox one.


#25

So, did the uninstalled, reinstall two more times. Then approached the boss from the north stairs instead of the south stairs that i had been using and it worked.


#26

So, I’m gonna give up, now it’s doing the exact same thing on the final boss on my NG run. At this point the game, no matter how fun it was, just isn’t worth the hassle.


#27

So when is this gonna get fixed? I’ve got 5 achievements left and can’t even start the last encounter cuz it keeps freezing then shutting off my Xbox.

Why was the response from a dev to reinstall the game? I did that and it didn’t work still.


#28

So… same thing happened to me. Twice. At the exact same place : right before the end boss of a dungeon.
I’ve recorded it here : http://xboxdvr.com/gamer/LEboueur/video/46952738 (in case it helps)

Fortunatly, each time I came back after the freeze, I have been able to fight the boss. But that made me lost some progress and time.

Also, the whole “console shut down after you close the game” is seriously worrying me. :s

EDIT: I play on a digital copy of the game on Xbox One X


#29

We will be releasing a patch soon, hopefully next week.

We’ve fixed a number of issues, including stability improvements, but I’m not 100% positive @Stepperot that this will fix your issue, since we weren’t able to reproduce it here. I’m cautiously optimistic, though.

Sorry!