World Map/Dungeon Frame Rate Stuttering


#1

Hey, guys,

I’ve been doing a lot of research on this in my spare time and checking out people’s hardware from reports about stuttering on the world map. It seems the vast majority of framerate issues are occurring on G-SYNC enabled NVidia video cards (my own at home included!)

In my research, I’ve got a series of suggestions for people to try:

  1. If you have an NVidia card with G-SYNC enabled, try disabling G-SYNC technology via the NVidia Control Panel for Battle Chasers specifically. You’ll want to go to:
  • Manage 3D Settings
  • Program Settings tab
  • Select Battle Chasers from the dropdown
  • Scroll down to the Monitor Technology and change the value from “G-SYNC” to “Fixed Refresh”
  • Scroll down to the Vertical Sync option and change the value to “Use the 3D application setting”
  • Click the Apply button at the bottom right.
  1. For people running Windows 10 and having issues, try launching Battle Chasers with the “-exclusive” command line argument.
  • On Steam, right click on Battle Chasers in your library, and select Properties.
  • Click the Set Launch Options button.
  • Write -exclusive in the text box, and select OK
  • Try running the game, and make sure full screen is enabled.
  1. We made some world map camera changes in patch 23636 that have reportedly helped some people with their framerate issues. Make sure you’re updated to this build or later.

Please report on here whether these suggestions make a difference. I’ll keep this updated if we find any other workarounds.
Thanks, guys!

Andres


#2