Workaround for crash on startup (playing intro video)


#1

A few people have had an issue getting the intro video to play, which results in crashing after the THQNordic and Airship logos play.

There’s a workaround that may help:

  • Double click Battle Chasers: Nightwar in Steam
  • You should see two choices. Pick the bottom one. (If you don’t see these yet, you may need to exit Steam completely and restart it.)

image

NOTE: This will make the game run using D3D 9 instead of D3D 11.

The post effects seem to be impacted, causing lots of blur in dungeons. To prevent this, in-game, go to Graphics Options and set Post Effects to “Low” or “Off”:

Thanks to @Kriger for working through different causes and fixes.


#2