Switch Code/Physical Update


#162

Yeah check your inventory, you should have Switch there to unlock.


#163

Same for me. It let me choose Switch NA and allowed me to finalize everything but no code was displayed or is displayed right now.


#164

Back out to the main menu and there’ll be a new option next to wallpapers and other bonus content


#165

Go back to your “inventory”, it should be there.


#166

From Canada, everything went flawlessly thanks Ryan and all Airship/THQ.


#167

Are you all on battlechasers.com/upgrade for these? Is there some other page of which I am not aware? Is Massachusetts -GASP- no longer in North America?


#168

Nothing shows up for me except for the Steam code (the free one? I barely remember). On my profile page, it says I had selected “Switch” on my survey, and I got the email about the Switch delay on Tuesday.


#169

I am downloading it now. Thanks!


#170

SUCCESS! I’m so happy to finally be downloading!


#171

The switch button finally showed up, make sure to clear your browsers cache guys.


#172

NA Switch code successfully received from website and worked on the Switch. It works! Thanks!


#173

@strangelove Thankyou Thankyou. Downloading as we speak. I take all my frustration comments back. I’m so excited you cannot not imagine how little slee I’m getting tonight lol. Please let me know what needs to happen for a DLC or sequel. I’m hoping THQ Nordic partners up with you to do additional content and titles.


#174

Hey aett, try now! Think I saw the problem


#175

Works, thanks sir! Its an amazing game and I’m very happy to get to play it on the go now!


#176

So relieved! Hope you enjoy it!


#177

I’m in Australia - does that mean I should download from North America or European version?

What’s the difference?


#179

I’m still not seeing a Switch option. Is https://www.battlechasers.com/upgrade the correct location?


#180

Hey whysgai, I PM’d you!


#181

An important note for peeps - if you upgraded to physical, yours will be coming in the mail! You can email jon@tinyfishprinting.com for shipping info if you didn’t get an e-mail. You won’t have a digital code to select.


#183

Did you guys already run out of NA codes? Just went to grab mine, and it’s showing as Currently Unavailable?