Switch Code/Physical Update


#205

Ok I have to go AFK for a bit - I’ll try to check back. Serious issues please direct to support@airshipsyndicate.com and we’ll try to respond ASAP tomorrow!


#206

My code is nowhere to be found in the inventory I try to redeem it but comes up empty… please help!


#207

Okay, I’ve Ctrl+F5’d and I can see the option to select it for NA now, but when I do, all I get is a screen with a grey box with the text

NINTENDO SWITCH (NORTH AMERICA)

A game code for Battle Chasers: Nightwar, redeemable on Nintendo Switch (North America).

And nothing else whatsoever. What the heck is going on, are your servers just overloaded? Or am I doing something wrong?


#208

It’s not where you would think it is. It’s a weird interface. You redeem then unlock. 2 steps. Inventory game code choice pick switch. Back to inventory scroll down find the switch and unlock. Then find it again and the code should be there.


#209

me too :frowning:

think need to wait for a while for it to sort it out…


#210

I got it! Downloading now. I’m seriously debating taking the day off tomorrow. Thanks for all the hard work guys!


#211

So close yet so far…


#212

Site issues as everyone runs to log in and get their codes, finally log in, also get gray box of nope. Log out, log back in, no “unlock” or “redeem” in inventory, further attempts yield identical results.

Gonna go make dinner happen. I’m sure they’re working on any issues. Fingers crossed I get to smile after stuffing my face with a rad game to play.


#213

I’m getting the exact same screen :frowning: no code.


#214

Yeah getting the same screen, logged in and out. Also tried a few different browsers… So close… so very close. My Switch is ready!


#215

I also get the same screen, with no way to actually get the code. Tried the same things others have suggested (refreshing, log out, clear cache, etc). No luck so far. :frowning:


#216

Hey guys, I’m in Australia - do I pick NA or EU?


#217

i would wait till a moderator replies they have an email to contact support

support@airshipsyndicate.com


#218

Same deal - My guess is that we are European version - because we are PAL format.

I haven’t tried yet my switch is at home


#219

Yeah, a quick Google tells me we are the EU/AU region


#220

Anyone that was getting the grey box of fail earlier might try again, just got through the process.


#221

I also just got through. Try again every few minutes if it’s still not working.


#222

If you were seeing a blank box for your switch code, please reload the page and see if it shows up. We had a problem which we just fixed.

If not, try logging in and out again.

Sorry for the inconvenience!


#223

Happy to say that the code redemption works for me now - logged in just to express thanks for finally being able to play! I’m sure I’m not the only one just dying to jump in.


#224

Whatever updated worked for me.
Downloading now!