Airship Community

[PC][Steam] Game not starting after intro

My issue is almost exactly the same as the user who posted [MAC][Steam] game unplayable after intro video

I am on a PC and have 15 hours logged in the game so far. After selecting start, the loading screen displays and the progress bar reaches approximately 60% then stops. The in-game sounds and music can be heard, however they cut in and out.

The last date I successfully played was 10/10. Since then I believe my computer auto-updated overnight. Not sure if that makes a difference.

If there is a log file to help with assisting, please let me know where to locate it on Windows 10.

Computer Information:
Manufacturer: Gigabyte Technology Co., Ltd.
Model: To be filled by O.E.M.
Form Factor: Desktop
Touch Input Detected

Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD FX™-8350 Eight-Core Processor
CPU Family: 0x15
CPU Model: 0x2
CPU Stepping: 0x0
CPU Type: 0x0
Speed: 4018 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: NVIDIA GeForce GTX 970
DirectX Driver Name: nvldumd.dll
Driver Version: 22.21.13.8494
DirectX Driver Version: 22.21.13.8494
Driver Date: 7 18 2017
OpenGL Version: 4.5
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: NVIDIA GeForce GTX 970
VendorID: 0x10de
DeviceID: 0x13c2
Revision: 0xa1
Number of Monitors: 3
Number of Logical Video Cards: 3
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 5760 x 1094
Primary Display Size: 18.74" x 10.55" (21.50" diag)
47.6cm x 26.8cm (54.6cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 4095 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Speakers (JBL Micro Wireless St

Memory:
RAM: 24536 Mb

Miscellaneous:
UI Language: English
Media Type: DVD
Total Hard Disk Space Available: 19191188 Mb
Largest Free Hard Disk Block: 800094 Mb
OS Install Date: Dec 31 1969
Game Controller: XInput Controller #1 detected
VR Headset: None detected

Sorry to hear that!

There should be a logfile in a directory like:
C:\Program Files (x86)\SteamLibrary\steamapps\common\Battle Chasers Nightwar\BC_Data\output_log.txt

Could you share that here? Or if the forum won’t let you post it, could you PM it to me?

I had a similar issue. I was playing the beta just fine, but once it updated via Steam, it stopped working. The intro video plays, then it just hangs on the initial loading screen at about 20%. I left it alone for a few hours and it was in the same place. I’m on a mac.

Let me know if there’s any other info you might need to help resolve this.

We have had an issue where the Mac build hangs until you click the mouse cursor on the game window. It seems to lose focus when playing through Steam. We have code in place that should work around this, but it doesn’t seem 100%.

We had another Mac user who had that problem, and when he updated his MacOS version, it worked properly again. That makes me wonder if maybe there’s something we’re relying on that’s missing somewhere.

We’ll look into it more, my apologies.

Hello, any update on this? I am still unable to play the game.