Game will not start up from steam


I just purchased Battle chasers on December 29th. I went to play it for the first time today and it won’t start up. You can see the icon appears on the task bar and you can hear the sound/music, but nothing ever comes up and eventually you just have to right click the icon and close it.

I tried verifying file integrity, I uninstalled and reinstalled the game, and nothing works. The same thing happens every time I try to start the game. What do I do?


Hey, @Bobafett:

We’re sorry you’re experiencing this! Have you found a solution to the problem?

If not, based on your description, it could be the game is maybe be offscreen, if you’ve had an extra monitor set up at some point.

You can try deleting your BCSettings.cfg file, located in the same directory as your saves (instructions here [PC/Mac] How to find Log/Save Files)

It gets recreated when it doesn’t exist.

Alternately, you could manually change the “screenIndex” or “fullscreen” properties in the file and see if they make a difference.


This is the exact error I’m seeing. I just bought the game on 2/15 and it behaves just like it does for Bobafett. I do not have a BCSetting.cfg file in the location listed. Here are my Steam system settings.

Computer Information:
Manufacturer: Dell Inc.
Model: Inspiron 5735
Form Factor: Laptop
No Touch Input Detected

Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD A8-5545M APU with Radeon™ HD Graphics
CPU Family: 0x15
CPU Model: 0x13
CPU Stepping: 0x1
CPU Type: 0x0
Speed: 1697 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Supported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver: AMD Radeon HD 8510G
DirectX Driver Name: aticfx32.dll
Driver Version: 15.200.1062.1004
DirectX Driver Version:
Driver Date: 8 3 2015
OpenGL Version: 4.5
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 60 Hz
DirectX Card: AMD Radeon HD 8510G
VendorID: 0x1002
DeviceID: 0x9999
Revision Not Detected
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 15.04" x 8.46" (17.24" diag)
38.2cm x 21.5cm (43.8cm diag)
Primary Bus Type Not Detected
Primary VRAM: 768 MB
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: sooper laod (Realtek High Defin

RAM: 7365 Mb

UI Language: English
Media Type: DVD
Total Hard Disk Space Available: 942547 Mb
Largest Free Hard Disk Block: 650750 Mb
OS Install Date: Dec 31 1969
Game Controller: None detected
VR Headset: None detected


Somebody on the Steam page posted the fix! Here is the link:

For AMD, I had to open AMD Catalyst, go to My Built-In Displays, and choose Use Centered Timings for Image Scaling Preferences.