BC.cfg Options!


#1

Hey, everyone!

Andres here with a little tutorial on the BC.cfg file!
We have a few config options that have not yet been added to the menus (since there’s a lot of other crucial fixes that are taking priority) but we added a quick way to enable some of these on PC^!

  1. Create a text file in the same directory as BC.exe
    (for Steam users, look for the Battle Chasers install directory - something like C:\Program Files\Steam\steamapps\common\Battle Chasers Nightwar)

  2. Opening this text file with a text editor like Notepad, you can enter any of the following lines to enable/disable features that might be giving you trouble. Make sure to enter these one per line, hitting enter between each.

  • set playVideos 0 - This will skip all videos in the game, if for any reason your machine is having trouble playing them due to video codecs, etc.

  • set clickHoldToMove 1 - This enables the experimental click and hold to move function, so players with a mouse can hold left click to move in that direction. Right click will also interact with objects.

  • set rumbleEnabled 0 - This will disable rumble on your controller.

  • set showInteractOutline 0 - - This will disable the interaction selection outline in dungeons.

  • set showCombatOutline 0 - This will disable the combat target selection outline.

  • set immediateScreenFreeze 1 - This will make pause menus/the book immediately gray out the background instead of doing so gradually, if this is causing performance issues on your machine.

We’ll update this post if additional options are added, and we’ll try to get these into the menus as soon as we can.

Thanks, everyone! Happy gaming!
Andres

^Really sorry, Mac and console players - we’ll get these features into the menus soon!


Crimson Garden Statue Interaction
BLACK SCREEN from Start of the game
Crashing On PC After Junktown Boss
Iron Outpost Boss Crash
#2

#3

Hello, I own the game on Steam. I created the BC.cfg, but my controller still rumbles at maximum with every combat action. The folder is the same as the screenshot, but the .exe in your screen is not a .exe in my folder its just “BC”. The game is unplayable to me if I have to deal with the rumble this often and at the highest vibration setting… It should rumble partially for crits or death blows maybe but on every attack its massively uncomfortable. Sorry to bother you with this, have a good day.


#4

Hey, @Mechalava!
In Windows explorer, you need to make sure file extensions are on in order to change the extension of BC.cfg :slight_smile:


Just make sure that box is checked, and you will see your BC.cfg is probably named something like BC.cfg.txt
Rename it then to BC.cfg - Windows will warn you that the file may not work, but just press OK. The rumbleEnable 0 feature should work then.


#5

Thanks so much! It works without the rumble now, time to go run some dungeons. I appreciate the fast reply, have a good day.